Closed Bug 844864 Opened 9 years ago Closed 9 years ago

Mozilla Developer Network Chinese Simplified entry site should be editable for contributors

Categories

(developer.mozilla.org Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: iwofox, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130220104816

Steps to reproduce:

try to edit it for translate the web page into real Chinese Simplified text


Actual results:

Failed to edit for translation


Expected results:

editable for localization contributors(cause nobody else care of if it is really in Chinese Simplified)
Do you see an error message when you try to translate?
If I was a developer speak Chinese from mainland China, it would be very sad and unbelievable that as the entry port of MDN for all native programer living in the biggest place of East Asia, this webpage has NONE words in Chinese 简体中文.
https://developer.mozilla.org/zh-CN/

The more sadly thing is us contributor can do NOTHING on it.(due to Kuma system authorize policy?)

Compared with Traditional Chinese entry of Taiwan, they got some kind comfort for at least top hyperlinks has been translated.
https://developer.mozilla.org/zh-TW/
(In reply to John Karahalis [:openjck] from comment #1)
> Do you see an error message when you try to translate?

No, cause there is no EDIT button at all!
Thanks for clarifying.

You need to use a different tool to localize that page. Please log in here to begin translating.

https://localize.mozilla.org/zh_CN/mdn/

That said, I agree that this is unintuitive. I will be sure we look into making this more clear in the future.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
(In reply to John Karahalis [:openjck] from comment #4)
> Thanks for clarifying.
> 
> You need to use a different tool to localize that page. Please log in here
> to begin translating.
> 
> https://localize.mozilla.org/zh_CN/mdn/
> 
> That said, I agree that this is unintuitive. I will be sure we look into
> making this more clear in the future.

Thanks for so quickly feedback to provide a solution in temporarily(for a dead horse maybe:)

Hope it'll be fixed for kuma in such Wierd settings.

Anyway I doubt this site(Mozilla Verbatim) whether could make it sense for this bug. 
https://localize.mozilla.org/zh_CN/mdn/

But still I'll try later. Thank you, John!
I should say it AGAIN to make it more clear:
It's NOT about localization of MDN on Verbatim project, that only cause some page element like button of sign_in\translate\this_page is still in English not in Chinese.

The problem here is in this webpage, there's NO d**n such translate\this_page button at all:
https://developer.mozilla.org/zh-CN/

It's about kuma system NOT permitted us contributors to edit above page.

We just wanna have an equal opportunity to help ourselves to make it appear just like
https://developer.mozilla.org/zh-TW/

Thank you all to take a look of this thread!
Again, I think you can use Verbatim to translate the home page. Luke (cc:'d here) should be able to say more.

I think your idea about allowing localizers to translate any page (including the home page) is a good one. I have mentioned it to our user experience designer, and will be sure we keep it in mind.
The difference is between the site UI strings stored in django and the wiki content stored in the database. The home and landing pages are part of the site UI, so we have to translate them with Verbatim.

That being said, Pontoon is an in-place, WYSIWYG localization tool that Mozilla Lab is working on to help with Firefox OS translation. It looks much more mature since the last time I looked at it, so it might be ready to wire up to MDN?

https://pontoon-dev.mozillalabs.com/
Pontoon looks incredible! I filed bug 845961 for that.
Thanks for clarifying.

You need to use a different tool to localize that page. Please log in here to begin translating.

https://localize.mozilla.org/zh_CN/mdn/

That said, I agree that this is unintuitive. I will be sure we look into making this more clear in the future.
2557181mm: If you need a Bugzilla sandbox, please use https://landfill.bugzilla.org/bugzilla-tip/
Cloud we just stop wasting time to wrangle and wait "up coming" upgrade of Kuma?

And let me(or someone else really wanna take this seriously) edit and translate that MDN Chinese homepage entry as a temporary solution in some time(like 15 days)!
It's only a special case and only for this page, or please let us know what we can do by NOW?

https://developer.mozilla.org/zh-CN/

Funny thing is, ironically this test page is NOT editable either.

https://developer-dev.allizom.org/zh-CN/

iwo@MDN
https://developer.mozilla.org/zh-CN/profiles/iwo

Thank you all!
Kuma has already been released.

You can edit the homepage right now. You need to do it here:
https://localize.mozilla.org/zh_CN/mdn/LC_MESSAGES/messages.po/translate/

Peter: Do you know anyone in the zh-CN community who could help iwo get started?
Flags: needinfo?(petercpg)
CC+ Jian Jin and Holy Wen for helps.
Flags: needinfo?(petercpg)
Maybe I know what has happened. 

https://localize.mozilla.org/zh_CN/mdn/

https://localize.mozilla.org/zh_TW/mdn/

There are 779 strings in zh_CN and 1575 strings in zh_TW. So many strings on the MDN page can not be translated to zh_CN.

For example:

https://localize.mozilla.org/zh_TW/mdn/LC_MESSAGES/messages.po/translate/?unit=1019159

This string shows in homepage of MDN. But it can not be found in zh_CN locale. So it can not be localized on zh_CN page.
Good find! That's definitely a bug.
Shen, can you please open a bug for the problem you mentioned in comment 15.
Product: developer.mozilla.org → developer.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.