Closed Bug 844890 Opened 8 years ago Closed 7 years ago

Use typed arrays for internal ParallelArray data structures

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 974201

People

(Reporter: nmatsakis, Unassigned)

References

Details

(Whiteboard: [PJS][js:t])

There are some internal PA data structures that are always known to be arrays of integers.  We currently use dense arrays to represent these, but typed arrays would likely be more efficient.  I decided to defer this refactoring because one would have to check and make sure that the construction of typed arrays works for the nested parallel use case.
Blocks: PJS
Whiteboard: PJS
Whiteboard: PJS → [PJS][js:t]
OS: Mac OS X → All
Hardware: x86 → All
Fixing this over in bug 974201.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 974201
You need to log in before you can comment on or make changes to this bug.