Closed Bug 844943 Opened 9 years ago Closed 9 years ago

PDF file with Form isn't working

Categories

(Firefox :: PDF Viewer, defect)

19 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 739043

People

(Reporter: gdagnelie, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

I am running Firefox in Windows XP Professional.  I upgraded to 19.0 last week and verified that all plug-ins were up-to-date.  I then went to a website that serves fillable PDF forms for workflows using Livelink software. 


Actual results:

I noticed that fillable content of the PDF forms did not show -- neither previously filled content (by other workflow participants) nor fields that should be available for me to fill; instead, only the form's pre-printed information was presented.  A warning bar popped up at the top of the page stating that an error had probably occurred while loading the PDF.  This same warning appears when loading other PDF content using the Adobe PDF plug-in.  To see an example of this warning, please follow this link: http://media.wix.com/ugd//0294e7_bf90565f1bbf135ec3966d15a2e6d59c.pdf



Expected results:

The previously filled content should have been visible to me, and the fillable fields should be visible and editable.
Firefox comes with a new integrated PDF viewer.
You can change it back to Acrobat in tools/options/applications/Portable document format PDF

moving to PDF viewer for the example PDF
Component: Untriaged → PDF Viewer
Thanks, Matti!

I should have realized that was why things were acting differently.  I chose Acrobat 9.5 as the application and everything is working as it used to.

Mozilla should probably add this to their FAQ and search -- I did not find it there.

Best regards,

Gislin Dagnelie
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
reopening, the pdf if still broken in the internal viewer and should not (i still have to test this)

The new integrated PDF viewer was in the news about FF19 and it should be in the release notes :-)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Summary: Version 19.0 appears to have a conflicted interaction with the Adobe PDF plugin → PDF file with Form isn't working
Duplicate of bug: 739043
You need to log in before you can comment on or make changes to this bug.