File upload selector control displays as text input box

RESOLVED DUPLICATE of bug 832923

Status

Firefox OS
Gaia::Browser
RESOLVED DUPLICATE of bug 832923
5 years ago
5 years ago

People

(Reporter: Brion Vibber, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 718061 [details]
screenshot of http://leuksman.com/misc/up on Firefox OS browser

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130225 Firefox/21.0
Build ID: 20130225042023

Steps to reproduce:

Tried to select a file with a file upload control at http://leuksman.com/misc/up

<input type="file">


Actual results:

The file selector control shows as a plaintext input. Tapping into it opens the keyboard and allows you to type.


Expected results:

Pop up a file selector that can be used to, at *least*, select photos or videos from the gallery app.
(Reporter)

Comment 1

5 years ago
I noticed bug 801635 (marked as 'fixed') requested disabling the file input controls. (huh?) Sounds like there needs to be more work before it's implemented or...?
(Reporter)

Comment 2

5 years ago
Per discussion in #gaia IRC channel I was able to confirm that the disabled file controls can be detected easily in JavaScript by checking the 'type' property on the control to see if it's set to "file". Not ideal, but we can work around it on Wikipedia for now.

But it's still disappointing not to have file uploads!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 832923
You need to log in before you can comment on or make changes to this bug.