Closed Bug 845193 Opened 9 years ago Closed 9 years ago

Consider implementing adb authentication

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 842747

People

(Reporter: dhylands, Unassigned)

References

Details

Android 4.2.2 (which I'm currently running on my Nexus 4) has support for the notion of authenticated adb.

This is supported in adb 1.0.31, and when adb tries to connect to the phone, the phone will show as "offline". The phone will present a prompt asking if its ok to connect the indicated host. Until the user acknowledges the prompt, the host will be unable to connect vi adb.

This makes adb dramatically more secure.
Blocks: gonk-jb
No longer blocks: gonk-jb
Depends on: gonk-jb
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 842747
You need to log in before you can comment on or make changes to this bug.