Closed Bug 845632 Opened 8 years ago Closed 7 years ago

Intermittent testBookmarksTab | Exception caught - junit.framework.AssertionFailedError: The text: Bookmarks is not found!

Categories

(Firefox for Android :: Awesomescreen, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: RyanVM, Assigned: gbrown)

References

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=20126803&tree=Firefox

Android Tegra 250 mozilla-central opt test robocop on 2013-02-26 17:18:18 PST for push ad4cc4e97774
slave: tegra-304

49 INFO TEST-PASS | testBookmarksTab | Context menu has New Tab option - Open in New Tab
50 INFO TEST-PASS | testBookmarksTab | Context menu has Share option - Share
51 INFO TEST-PASS | testBookmarksTab | Context menu has Edit option - Edit
52 INFO TEST-PASS | testBookmarksTab | Context menu has Remove option - Remove
53 INFO TEST-PASS | testBookmarksTab | Context menu has Add to Home Screen option - Add to Home Screen
54 INFO TEST-PASS | testBookmarksTab | Folders have no context menu - false should equal false
Exception caught during test!
junit.framework.AssertionFailedError: The text: Bookmarks is not found!
	at junit.framework.Assert.fail(Assert.java:47)
	at junit.framework.Assert.assertTrue(Assert.java:20)
	at com.jayway.android.robotium.solo.Clicker.clickOnText(Clicker.java:330)
	at com.jayway.android.robotium.solo.Solo.clickOnText(Solo.java:839)
	at org.mozilla.fennec.tests.testBookmarksTab.checkBookmarkEdit(testBookmarksTab.java:214)
	at org.mozilla.fennec.tests.testBookmarksTab.testContextMenu(testBookmarksTab.java:156)
	at org.mozilla.fennec.tests.testBookmarksTab.testBookmarksTab(testBookmarksTab.java:47)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.fennec.tests.BaseTest.runTest(BaseTest.java:130)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
55 INFO TEST-UNEXPECTED-FAIL | testBookmarksTab | Exception caught - junit.framework.AssertionFailedError: The text: Bookmarks is not found!
56 INFO TEST-END | testBookmarksTab | finished in 99488ms
Geoff, did http://hg.mozilla.org/mozilla-central/rev/5228ec314dc9 regress this?
Blocks: 798683
Flags: needinfo?(gbrown)
(In reply to Ed Morley [:edmorley UTC+0] from comment #3)

I agree that the regression timing suggests bug 798683, but I don't see how that change could result in this failure. I would prefer not to back out that change, but rather see how this failure reacts to the patch coming in bug 769919.
Flags: needinfo?(gbrown)
Assignee: nobody → gbrown
All of these failures are on tegra-304.
Depends on: tegra-304
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: tegra-304
Looks like tegra-355 has the disease now.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
9 in a row on tegra-355. The logs show crashes in com.android.inputmethod.latin.
Depends on: tegra-355
I can find no record of changes to tegra-355, but there have been no new failures in 6+ weeks now.
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.