Closed Bug 845752 Opened 7 years ago Closed 6 years ago

Profiler leaks when opened and closed quickly.

Categories

(DevTools :: General, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 25

People

(Reporter: Optimizer, Assigned: Optimizer)

References

Details

Attachments

(1 file)

This might be due to remote connection, or simply a profiler related issue, so CC'ed both Panos and Anton.

See https://bugzilla.mozilla.org/show_bug.cgi?id=838069#c13 for more information on how to reproduce. Bug 838069 will disable the test of opening the profiler via the shortcut key in the test "devtools/framework/test/browser_toolbox_window_shortcuts.js". Please re-enable that test when this leak is fixed.

Thanks.
Depends on: 838069
Depends on: 879008
I can't reproduce this locally. Is it still an issue for you?
Flags: needinfo?(scrapmachines)
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #1)
> I can't reproduce this locally. Is it still an issue for you?

I actually can't pin point this to Profiler. May be its profiler, or debugger or webconsole.

But I sure can tell you a way to reproduce the leak. Just try to run the test browser_toolbox_window_shortcuts.js with this [0] check removed on Windows XP or Mac OSX 10.6

The test opens all tools side by side.

If you cannot find the leak, then it might have gotten fixed by some other bug :)

[0] http://mxr.mozilla.org/mozilla-central/source/browser/devtools/framework/test/browser_toolbox_window_shortcuts.js#21
Flags: needinfo?(scrapmachines)
I am using a debug build at the moment so I will take a look.
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Mike, any luck with this?
(In reply to Rob Campbell [:rc] (:robcee) from comment #4)
> Mike, any luck with this?

Oops, I thought I had unassigned myself. Last I tried I couldn't reproduce the issue.
Assignee: mratcliffe → nobody
Closing, since nobody can reproduce the issue. Re-open if you can.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Its more like nobody has tried to reproduce. I will reenable jsprofiler that was disabled in bug 838069 and pass it through try to see if it is actually fixed or not.
Assignee: nobody → scrapmachines
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Both Michael and myself couldn't reproduce. Anyway, removing it from the Profiler since you couldn't pinpoint to the Profiler in comment #2.
Component: Developer Tools: Profiler → Developer Tools
Then let's enable profiler in the shortcuts test and land it. If there are no leaks on inbound, then that will confirm that profiler is not the culprit.
Why can't you use Try?
because in the original bug also, try never showed those leaks. It was only inbound that was showing the leaks. And by never, I mean I tried really hard to see the leaks over multiple try runs with multiple rebuilds.
try push with profiler enabled : https://tbpl.mozilla.org/?tree=Try&rev=cc819fb26341

[This is just precaution, personally try never gave the leaks]
Let us re enable profiler in the toolbox shortcut test and see what happens.
Attachment #777200 - Flags: review?(anton)
Comment on attachment 777200 [details] [diff] [review]
reenable proflier in shortcut tests

Review of attachment 777200 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #777200 - Flags: review?(anton) → review+
landed in fx-team : https://hg.mozilla.org/integration/fx-team/rev/101c751178df
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/101c751178df
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 25
No longer depends on: 879008
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.