Closed Bug 846410 Opened 8 years ago Closed 7 years ago

[OS.File] Atomic JSON lzived write

Categories

(Toolkit :: OS.File, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 854169

People

(Reporter: Yoric, Unassigned)

References

(Depends on 1 open bug)

Details

No description provided.
taras, what's the priority of this feature?
Flags: needinfo?(taras.mozilla)
(In reply to David Rajchenbach Teller [:Yoric] from comment #1)
> taras, what's the priority of this feature?

It's something we *should* support aka low.
Flags: needinfo?(taras.mozilla)
i think we should do this with lz4 if possible. lz4 is effectively zero-overhead for decompression and almost-free for compression
I believe that we do not have lz4 in-tree yet. Do you want us to add http://code.google.com/p/lz4/ to our code?
(In reply to David Rajchenbach Teller [:Yoric] from comment #4)
> I believe that we do not have lz4 in-tree yet. Do you want us to add
> http://code.google.com/p/lz4/ to our code?

that's my proposal. I think we need another vote from someone to proceed.
Ok, putting bug 854169 on hold until I have news on the results of the vote.
Depends on: 848223
Summary: [OS.File] Atomic JSON gzipped write → [OS.File] Atomic JSON lzived write
Whiteboard: [Async:P1]
Whiteboard: [Async:P1] → [Async:team]
Actually, this has basically been fixed by bug 854169.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 854169
Whiteboard: [Async:team]
You need to log in before you can comment on or make changes to this bug.