Closed Bug 846639 Opened 8 years ago Closed 8 years ago

Intermittent test_selection_underline.html | Assertion count 4 is greater than expected range 0-3 assertions (Destroying a currently-showing document: '!mIsShowing')

Categories

(Core :: Layout, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 671976

People

(Reporter: philor, Unassigned)

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=20210342&tree=Mozilla-Inbound&full=1
Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-other on 2013-02-28 21:40:04 PST for push 5aa0d1771419
slave: talos-r3-w7-092

21:56:20     INFO -  12699 INFO TEST-PASS | chrome://mochitests/content/chrome/layout/generic/test/test_selection_underline.html | Rendering of reftest (selection: SpellCheck, style: solid, relativeSize: 1, font: AhemTest, default font size: 16) is different
21:56:20     INFO -  RESULT=undefined
21:56:20     INFO -  REFERENCE=undefined
21:56:20     INFO -  [Parent 1096] ###!!! ASSERTION: Destroying a currently-showing document: '!mIsShowing', file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/content/base/src/nsDocument.cpp, line 1370
21:56:20     INFO -  [Parent 1096] ###!!! ASSERTION: Destroying a currently-showing document: '!mIsShowing', file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/content/base/src/nsDocument.cpp, line 1370
21:56:20     INFO -  [Parent 1096] ###!!! ASSERTION: Destroying a currently-showing document: '!mIsShowing', file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/content/base/src/nsDocument.cpp, line 1370
21:56:20     INFO -  [Parent 1096] ###!!! ASSERTION: Destroying a currently-showing document: '!mIsShowing', file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/content/base/src/nsDocument.cpp, line 1370
21:57:47     INFO -  12900 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/generic/test/test_selection_underline.html | Assertion count 4 is greater than expected range 0-3 assertions.
Thanks for filing this.  However, duping to existing bug we were using for tracking this.

I just added SpecialPowers.gc() calls to the causing tests so that this is stable and stops bouncing between tests (see dupe target).
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671976
You need to log in before you can comment on or make changes to this bug.