Last Comment Bug 846832 - AWSY: ~22MB regression in explicit/resident memory usage on 25 feb
: AWSY: ~22MB regression in explicit/resident memory usage on 25 feb
Status: VERIFIED FIXED
[MemShrink]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: general
Mentors:
Depends on:
Blocks: 700023
  Show dependency treegraph
 
Reported: 2013-03-01 10:33 PST by (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2013-03-27 11:42 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2013-03-01 10:33:48 PST
See https://areweslimyet.com/mobile/ circa 25 feb - the pushlog range for the regression is http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=179a23a14368&tochange=cdc3588c8ce2
Comment 1 Jonathan Kew (:jfkthame) 2013-03-04 04:00:54 PST
See bug 700023 comment 10 for explanation. I've posted a patch there to revert the pref on Android for now, and filed bug 847344 about improving our use of the API so as to reduce the RAM impact.
Comment 2 Nicholas Nethercote [:njn] 2013-03-04 14:18:31 PST
Thanks!  I'll mark this as fixed, since the regression has been undone.
Comment 3 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2013-03-27 11:42:17 PDT
Just to follow up, the AWSY mobile graph is now catching up on the backlog, and the pref-flip does appear to have fixed the regression. Thanks!

Note You need to log in before you can comment on or make changes to this bug.