Crash provider failing if profile directory on UNC-formatted path: Module Path cannot handle UNC-formatted paths yet: \\foo\AppData\Roaming\Mozilla\Firefox\Crash Reports\pending

RESOLVED DUPLICATE of bug 846848

Status

Firefox Health Report
Client: Desktop
P4
normal
RESOLVED DUPLICATE of bug 846848
5 years ago
5 years ago

People

(Reporter: gps, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
FHR errors in the payload have revealed a failure of the crashes provider if the profile directory is on a network share:

Error: Module Path cannot handle UNC-formatted paths yet:
\\foo\AppData\Roaming\Mozilla\Firefox\Crash
Reports\pending

Possible OS.File limitation?

Can anyone weigh in on the importance of obtaining this data? Do we have any kind of idea how many Firefox users have their profile on a network share? That seems like something that would be interesting for FHR to collect. I imagine profile on a network share would slow down Firefox!
Definitely a limitation of OS.File: http://dxr.mozilla.org/mozilla-central/toolkit/components/osfile/ospath_win_back.jsm#l256

Opening bug 846848 for UNC-formatted paths. I'll let you tell me how urgent this is for you.
ASAP, please, Yoric!

P4 here just means "less important than FHR on Android".
Depends on: 846848
Priority: -- → P4
I have a prototype for bug 846848. Is there a way you could contribute a test?
(Reporter)

Updated

5 years ago
Component: Metrics and Firefox Health Report → Client: Desktop
Product: Mozilla Services → Firefox Health Report
(Reporter)

Comment 4

5 years ago
I'm going to assert this is fixed with bug 846848.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 846848
You need to log in before you can comment on or make changes to this bug.