[MMS][SMS][Tests] add tests and simplify Utils

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: rwaldron, Assigned: rwaldron)

Tracking

unspecified
x86
macOS

Firefox Tracking Flags

(b2g18 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Simplify Utils.getFormattedHour(time) and provide tests to support the expected behaviour
(Assignee)

Updated

6 years ago
Summary: [MMS][Tests] Simplify Utils.getFormattedHour → [MMS][SMS][Tests] add tests and simplify Utils
(Assignee)

Comment 1

6 years ago
This will address all of the non-DOM functionality in Utils.* (sms/js/utils.js)
(Assignee)

Comment 2

6 years ago
Created attachment 720135 [details]
Redirect to https://github.com/mozilla-b2g/gaia/pull/8414

Tests and code simplification for sms/js/utils.js
Attachment #720135 - Flags: review?(felash)
Comment on attachment 720135 [details]
Redirect to https://github.com/mozilla-b2g/gaia/pull/8414

r=me with the last comments fixed

thanks a lot
Attachment #720135 - Flags: review?(felash) → review+
(Assignee)

Comment 4

6 years ago
Fixed, rebased, squashed and pushed: https://github.com/mozilla-b2g/gaia/pull/8414
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Comment on attachment 720135 [details]
Redirect to https://github.com/mozilla-b2g/gaia/pull/8414

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: no
Testing completed: yes, the sms app works fine
Risk to taking this patch (and alternatives if risky): low, we added unit tests for each function of this file.
String or UUID changes made by this patch: none

I'd like this on v1-train because this brings unit tests, probably some minor perf improvement, and we'll need this in upcoming patches as well.
Attachment #720135 - Flags: approval-gaia-v1?(21)
Attachment #720135 - Flags: approval-gaia-v1?(21) → approval-gaia-v1+
Uplifted commit 57a600dca3d3af68cb71b399f11096fb0e367017 as:
v1-train: 07b494e9e1a4f29ac2f7ae4bfa408c8da1a77ec2
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.