Search engine checkbox on sidebar search tab doesn't always work

RESOLVED WORKSFORME

Status

P4
major
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: bugzilla3, Assigned: samir_bugzilla)

Tracking

({platform-parity, polish})

Trunk
Future
x86
Linux
platform-parity, polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; rv:0.9+)
Gecko/20010605
BuildID:    2001060511

Okay, sorry this is such a Heisenbug, but sometimes i simply can't select a
particular search engine's checkbox in the search tab of the sidebar. I just
installed 0.91 and even blew away my .mozilla first (keeping nothing but my old
bookmarks). 

To try to figure out why this is happening, i opened the sidebar, set moz to
display a blank page on startup, and closed it. Then launched it. The only thing
i clicked was the checkbox next to Google. It didn't get an X in it. It just
stayed blank. Then i closed Moz, launched it again, and did the same. This time
it worked. 

Then i repeated the process about a dozen times. There didn't seem to be any
pattern. Sometimes the checkbox just doesn't seem to want to get checked.

The box "bounces" -- in other words, the little animation of it getting pressed
in and popping back out works. But no little X appears and it's not included in
the search. 

If, in a particular session, it works once, it will keep working. If it doesn't
work once, it never does for that session.

Reproducible: Sometimes

Comment 1

18 years ago
Hello!

Yes, I got the same bug, but seems that after rechoosing search category ("Web", 
"All engines" etc.) everything is ok - U can normaly check checkboxes. So 
probably bug is connected with pre-loaded user settings (last choosed category) 
on new opened Mozilla window.

Comment 2

18 years ago
cc: claudius.

Comment 3

18 years ago
changing component to search; changing qa_contact to claudius
Component: Sidebar → Search
QA Contact: sujay → claudius

Comment 4

17 years ago
marking NEW based on confirmation.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
Testcase (0.9.3 linux):
- open mozilla
- Set advanced search
- select search sidebar
- select *any* category (even with a single engine)
- select several engines
- close mozilla
- restart mozilla

Then mozilla opens with the last settings, ie: search sidebar opened.

current : search engin check box are unaffected if one clicks on them
expected: check box flagged or unflagged

Comment 6

17 years ago
I just checked that even we can not see it, engines are selected or unselected
when clicking on checkbox. (to know it, you can just change the category and
reselect the previous category)
So it is a UI problem.

The test case is always reproducible.

Comment 7

17 years ago
(sorry for the spam)
Precision:
only the engines that have been previously selected will show this bug.
The checkboxes of the previously unselected ones have a normal behaviour.
(tested on Linux 2.2 2001081715 and MacOs 9.2 NS6.1)

Updated

17 years ago
OS: Linux → All
Hardware: PC → All

Updated

17 years ago
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 8

17 years ago
Taking for mozilla0.9.9.
Assignee: matt → sgehani
Keywords: polish
Priority: -- → P4
Target Milestone: mozilla1.0 → mozilla0.9.9
(Assignee)

Comment 9

17 years ago
Search triage team: -> Future
Target Milestone: mozilla0.9.9 → Future

Comment 10

17 years ago
This has been working for me since 0.9.8, without exception, on Win98. Reporter,
and anyone else watching this bug, are you still having this problem? Or can
this one be considered resolved fixed?
(Reporter)

Comment 11

17 years ago
Well, i stopped using the Sidebar about six months ago, so it certainly may have
been fixed. Feel free to close this bug unless someone speaks up.

Comment 12

17 years ago
No, this bug is still alive (linux build 2002 02 28 08).
To summarize:
1) Create a new profile and don't close the sidebar
2) Edit > Preference > Navigator > Internet Search
3) Check advanced Search and close the preference window
4) Select the search tab

Expected result: Netscape search engine is checked
Actual result: it is unchecked but is indeed used for advanced search

5) check the Netscape search engine
6) close mozilla (there is no Quick Launch in Linux)
7) Reopen mozilla with the same profile

Expected result: Netscape search engine should be checked
Actual result: it is still unchecked

At this point:
- clicking on the Netscape search engine does not toggle the mark (whereas it
was working in step 5)
- clicking on the other search engine works

Comment 13

17 years ago
Pierre: Is this just happening on Linux then? It works for me on Win98 with the
March 1st nightly build.

Comment 14

17 years ago
WFM WinME 2002030508 (except that the trivial bug after step 4 is present)
setting pp keyword and Linux OS, however I don't know if this bug happens on MAC
rainsing severity since it hampers/confuses the use of the advanced search feature.
Severity: minor → major
Keywords: pp
OS: All → Linux
Hardware: All → PC

Comment 15

17 years ago
This bug seems to have dissapeared for me.

I used to be able to reproduce it, but no more.

Using build 2002041408

Comment 16

17 years ago
marking WFM..

Mike, if you can still reproduce then REOPEN...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.