Closed Bug 846945 Opened 7 years ago Closed 7 years ago

work - downloaded / saved files should be searchable from the Metro Search charm

Categories

(Firefox for Metro Graveyard :: File Handling, defect)

x86
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 22

People

(Reporter: asa, Assigned: bbondy)

References

Details

Attachments

(1 file)

When I save files in Firefox Metro, they are often not available to the Metro search charm. 

Steps to reproduce:
1. visit http://www.blueskyfootage.com/Video_Formats/#format3
2. click the link "Click to Download and Evaluate a H264 HD Quicktime Clip"
3. wait for download to complete
4. swipe in the charms bar and tap Search. 
5. type "40" into the search field

Expected results:
see the file 40-042731-H264hdFormatSample.mov listed in the search results.

Actual results:
the file isn't listed.
Hi Asa, do you want this put as a Defect for work on Iteration #4 or moved to triage for consideration later on?
Flags: needinfo?(asa)
(In reply to Marco Mucci [:MarcoM] from comment #1)
> Hi Asa, do you want this put as a Defect for work on Iteration #4 or moved
> to triage for consideration later on?

This isn't a defect because we never specified that it should work. I guess that makes it a new story. I'd love to see someone pick  this up soon because I was counting on this working when I scaled back our download management plans.
Flags: needinfo?(asa)
Hi Asa, I'll add it to triage until you make a story for it or attach it as a work item to an existing story.
Assignee: nobody → netzen
I looked into this Asa and here's what's happening.

For some MIME types we have a default action for "open".
In metro we just use the default instead of showing UI to pick whether to open or save at the moment. Maybe this UI is part of the download appbar story? If so this can probably be resolved as invalid.

When the default action is "open" we always save to temp, and then open.  This is the same as on Desktop Firefox when you select to open.

Things only show up in the start screen when you save to a known location.

You can see this is true by going to:
http://people.mozilla.org/~bbondy/
And then downloading msvcr110d.dll  (tap to save when it says it can't open it).
You'll notice it is searchable. 

We could change to always put things that are open only and not save into the downloads folder, but this would be inconsistent with Desktop Firefox.
Component: General → File Handling
I'm OK with inconsistency with desktop.  On desktop, we have a downloads manager and a file manager that help users locate saved files. On Metro, we only have Windows search and that needs to work for all downloaded/saved files, I think.
OK I can do this with the inconsistent metro/desktop behavior as a defect in it4 if you'd like.
Blocks: 850415
OK, I've created a new story Bug 850415 - Story - Locate downloaded or saved files using Windows Search and made this bug a work item that blocks the new story.
No longer blocks: metrov1triage
Summary: downloaded / saved files should be searchable from the Metro Search charm → work - downloaded / saved files should be searchable from the Metro Search charm
Whiteboard: [mvp?]
Attached patch Patch v1.Splinter Review
Attachment #729003 - Flags: review?(jmathies)
Attachment #729003 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/598104a2101b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.