svg does not render in certain scales

RESOLVED DUPLICATE of bug 1077745

Status

()

RESOLVED DUPLICATE of bug 1077745
6 years ago
4 years ago

People

(Reporter: antonioubyron, Unassigned)

Tracking

({regression, testcase})

19 Branch
x86_64
Windows 7
regression, testcase
Points:
---

Firefox Tracking Flags

(firefox19 affected, firefox20- affected, firefox21- affected, firefox22- affected, firefox23 affected, firefox24 affected, firefox25 affected, firefox26 affected, firefox-esr17 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

http://www.e-domisis.gr/e-domisis_oroi-domisis/otsvgDemo.php?output1=113/2&output5=demo

Zoom into a map.



Actual results:

Some svg elements disappear. This happens both before (i.e. with the svg elements already at the browser) and after the ajax request (i.e. with the new data). 


Expected results:

Svg elements should continue to appear. The application still runs fine with older than FF 19 versions.
Component: Untriaged → SVG
Product: Firefox → Core

Comment 1

6 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/21195f52311c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121219 Firefox/20.0 ID:20121219134323
Bad:
http://hg.mozilla.org/mozilla-central/rev/868b21bed3eb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121220 Firefox/20.0 ID:20121220130628
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=21195f52311c&tochange=868b21bed3eb


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7d7600c0d5d0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121220 Firefox/20.0 ID:20121220044823
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/5589176b4f58
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121220 Firefox/20.0 ID:20121220060821
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7d7600c0d5d0&tochange=5589176b4f58

Suspected:
022244d0ca81	Robert Longson — Bug 791675 - Scaled shapes fail to draw sometimes r=jwatt.
Blocks: 791675
Status: UNCONFIRMED → NEW
status-firefox19: --- → affected
status-firefox-esr17: --- → unaffected
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
tracking-firefox22: --- → ?
Ever confirmed: true
Keywords: regression
Robert what are the options here?  Can we backout bug 791675 to remove this regression from FF20 or do you have an idea for a low risk forward fix we could take for beta 3 (tomorrow), at the latest before beta 4 (next Tues)?
Assignee: nobody → longsonr
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → affected
tracking-firefox20: ? → +
tracking-firefox21: ? → +
tracking-firefox22: ? → +
URL isn't loading for me -- it tries to load and then times out after a minute or so, saying:
  Server not found
  Firefox can't find the server at www.e-domisis.gr.
Keywords: testcase-wanted
(In reply to Lukas Blakk [:lsblakk] from comment #2)
> Robert what are the options here?  Can we backout bug 791675 to remove this
> regression from FF20 or do you have an idea for a low risk forward fix we
> could take for beta 3 (tomorrow), at the latest before beta 4 (next Tues)?

You could backout bug 791675 but then other drawings would not render. It's a toss up how many are affected in each case but if you go by the number of bugs raised it's about even.

Unfortunately cairo only works on a limited scale of numbers. We're trying to make it display properly with stuff that most people use but we have to guess what range that is.

bug 791675 makes things work more like earlier versions of Firefox (before SVG display lists) so I think it would be better if it stayed in overall.

We can remove our dependence on cairo for getting bounding boxes by calculating them ourselves. That's easy for rectangles, somewhat more difficult for cubic splines but long term that's what we should do. I'll try to do that but it will take some time.
Given that this will be a longer project to remove our dependence on cairo I'll remove tracking and we can keep to working as much like earlier versions of Firefox as the best solution for now.
tracking-firefox20: + → -
tracking-firefox21: + → -
tracking-firefox22: + → -

Comment 6

6 years ago
I can add a fairly simple SVG file showing the error. This is a pared down version of a practical example from production. It is from a map display, using geographical coordinates in the UTM Zone 32 projection system (a well-known standard, counting in meters) and the SVG scale transform to zoom in and out. In this case, the error kicks in at a scale which corresponds to somewhere near 0.75 meters per pixel, which is definitely not a pathological use case.
The line is showing in FF18, as well as in Chrome and Internet Explorer with Adobe's SVG plugin, but fails to show in FF19 and 20beta.

Updated

6 years ago
status-firefox23: --- → affected
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → affected
Keywords: testcase-wanted → testcase
Assignee: longsonr → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1077745
You need to log in before you can comment on or make changes to this bug.