jit-tests no longer run as part of make check on buildbot jobs

RESOLVED FIXED in mozilla22

Status

defect
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: jandem, Assigned: gps)

Tracking

(Blocks 1 bug)

unspecified
mozilla22
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I just pushed a patch with a failing jit-test to try [1] and only the root-analysis build caught it. The browser build itself was green, even though I'd expect it to run jit-tests too, as part of "make check".

Looking at a random mozilla-inbound log [2], it seems we no longer run jit_test.py as part of the build/"make check".

[1] https://tbpl.mozilla.org/?tree=Try&rev=275bd5815a2f
[2] For instance https://tbpl.mozilla.org/php/getParsedLog.php?id=20292731&tree=Mozilla-Inbound&full=1
Suspect bug 638219 is relevant to this.

(Adjusting summary, since TBPL is but a dashboard :-))
Summary: jit-tests no longer run on TBPL → jit-tests no longer run as part of make check on buildbot jobs
It's likely fallout from bug 784841
I don't think bug 638219 is relevant to this, but I'm afraid I don't have a good enough grasp of the tools here to make that conclusive. In any case, the recently-landed patch for bug 638219 only changed Python code that runs as part of the test harness, not the invocations of that code.
It's confirmed fallout from bug 784841: make check doesn't recurse js/src anymore because it's in tier_js_staticdirs, while it was tier_js_dirs before. And tier_*_staticdirs are not recursed for make check.
Blocks: 784841
(In reply to Mike Hommey [:glandium] from comment #4)
> It's confirmed fallout from bug 784841: make check doesn't recurse js/src
> anymore because it's in tier_js_staticdirs, while it was tier_js_dirs
> before. And tier_*_staticdirs are not recursed for make check.

Good times.

It has to be a static directory in a moz.build world because otherwise the moz.build reader will apply m-c's main config.status to the files in /js/src and the world will burn.

I hate to say it, but we may just want to one-off js/src as a check:: rule in a random Makefile.in (the root one?).
So jit-tests are not appearing anywhere on TBPL? That is pretty serious - Gregory, is this easy to fix or should we back out bug 784841?
(In reply to David Anderson [:dvander] from comment #6)
> So jit-tests are not appearing anywhere on TBPL? That is pretty serious -
> Gregory, is this easy to fix or should we back out bug 784841?

Bug 784841 is not being backed out. I'll code up a dirty patch...
Assignee: nobody → gps
Status: NEW → ASSIGNED
The easiest way to do it.
Attachment #720806 - Flags: review?(mh+mozilla)
Attachment #720806 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/84804140759e
Blocks: 846425
Target Milestone: --- → mozilla22
https://hg.mozilla.org/mozilla-central/rev/84804140759e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.