[Holo] Flat UI for Doorhangers

RESOLVED FIXED in Firefox 22

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

unspecified
Firefox 22
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Assignee)

Description

6 years ago
Currently doorhangers are shown in a dark background with shadows. The button bar changes with the phone and doesn't look good with Holo theme. It would be nice to have doorhangers and site identity popups use a lighter theme: http://cl.ly/image/0H1S113Y0Q0z
(Assignee)

Comment 1

6 years ago
Created attachment 720894 [details] [diff] [review]
Part 1: Doorhangers

This removes all blacks (yay!) and uses popup-backgrounds similar to custom menu. The phone ones have to be edge-to-edge, while the tablet ones are smaller. Hence two versions are used (PopupWindow cannot go past screen boundaries :( ). Removed the resources that aren't needed.
Attachment #720894 - Flags: review?(mark.finkle)
(Assignee)

Comment 2

6 years ago
Created attachment 720895 [details] [diff] [review]
Part 2: Doorhanger buttons

Buttons were using button-bar style. This is removed, and a new style is provided by inflating the button from the XML. The background is same as the content portion. An optional divider is shown, if buttons are visible.
Attachment #720895 - Flags: review?(mark.finkle)
(Assignee)

Comment 3

6 years ago
Created attachment 720898 [details] [diff] [review]
Part 3: Dividers

This patch adds dividers between buttons. Also, dividers (orange! yaay!) between doorhangers. Basically the orange divider is part of the individual doorhanger. They are shown/hidden based on the list that is about to be shown (last one's divider is hidden).

(The other approach could be to use a DoorHangerAdapter and show a list view. But things would get more complex in that approach).
Attachment #720898 - Flags: review?(mark.finkle)
(Assignee)

Comment 4

6 years ago
Created attachment 720899 [details] [diff] [review]
Part 4: Larry

No more shadows for Larry! (But who named him larry, btw?)
The UI is flat (one section of text, image on the right top).
Attachment #720899 - Flags: review?(mark.finkle)
(Assignee)

Comment 5

6 years ago
Created attachment 720901 [details] [diff] [review]
Part 5: Remove views

There are so many text-views in SiteIdentity popup. Removed some of them.
Attachment #720901 - Flags: review?(mark.finkle)
(Assignee)

Updated

6 years ago
Blocks: 715572
Attachment #720894 - Flags: review?(mark.finkle) → review+
Comment on attachment 720895 [details] [diff] [review]
Part 2: Doorhanger buttons

Let's double check with Ian on the colors
Attachment #720895 - Flags: review?(mark.finkle) → review+
Comment on attachment 720898 [details] [diff] [review]
Part 3: Dividers

fixDoorHangerDividers -> showDividers
Attachment #720898 - Flags: review?(mark.finkle) → review+
Comment on attachment 720899 [details] [diff] [review]
Part 4: Larry

Again, let's double check with Ian on the larry color changes
Attachment #720899 - Flags: review?(mark.finkle) → review+
Attachment #720901 - Flags: review?(mark.finkle) → review+

Updated

6 years ago
Duplicate of this bug: 808248

Updated

6 years ago
No longer blocks: 715572
You need to log in before you can comment on or make changes to this bug.