Closed Bug 847650 Opened 8 years ago Closed 7 years ago

Contacts' "new" activity is also "edit" in disguise

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: st3fan, Unassigned)

References

Details

I am not sure if this was intentional or not so I am filing a bug for it as it could also maybe used for evil.

The Contacts app handles a "new" activity. But, when you pass this activity an "id" parameter and an "extra" object, it becomes an "edit" activity.

If this is something that is just used internally then I think something should be in place to make sure third party apps don't use this. If it is a public API then I would suggest to move it to an "edit" activity instead.
You are right, that was made by design.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.