Closed Bug 847791 Opened 9 years ago Closed 9 years ago

Make sessionstore.js backup atomic on Windows using hard links.

Categories

(Firefox :: Session Restore, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 833286

People

(Reporter: yzen, Assigned: yzen)

References

Details

This bug is the same as Bug 833286 but is specific only to Windows platform. 
It requires some investigation into using hard link functionality on windows and determining whether it can be considered stable for this purpose.

In case it is, the backup of sesssionstore.js file should happen through the same steps as described in Bug 833286.

When writing for the first time to the sessionstore.js file:
* create a hardlink pointing to sessionstore.js, calling it sessionstore.bak;
* write data to sessionstore.js.tmp;
* finally, rename sessionstore.js.tmp to sessionstore.js.
Assignee: nobody → yura.zenevich
Now that we have landed Bug 833286, this one isn't needed anymore.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 833286
You need to log in before you can comment on or make changes to this bug.