Last Comment Bug 847875 - Page-scrolling on touchscreendevices fails when using some pages with JS enabled
: Page-scrolling on touchscreendevices fails when using some pages with JS enabled
Status: RESOLVED DUPLICATE of bug 736048
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 19 Branch
: x86_64 Windows 7
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-05 04:15 PST by franz.haertl
Modified: 2013-04-12 02:09 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description franz.haertl 2013-03-05 04:15:06 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

- the following occurred while operating ff using a touchscreen only. 

- I used Google for executing a search
- the bug occured for both using the searchbar and going to google.com 
- on the results-page I tried to scroll down by swiping upwards like it used to work before updating to ff19
- I tried to use the scrollbar on the right to scroll down after swiping had failed


Actual results:

- the page did not scroll up or down
- instead ff selected the text of the searchresults as I was swiping up
- when trying to use the scrollbar it behaved weirdly. The bar apeard to jump up and down, and most of the time scrolled upwards when I actually dragged it down and vice versa
- I tried a few things and found that deactivating JS for the google-site and reloading actually restores both swiping and scrollbar-operation to normal.
- the error occurred on a few other pages as well, and deactivating JS and reloading helped there as well.



Expected results:

- normal scrolling should have happened (scrolling up on downswipe, down on upswipe, normal scrollbar-operation

- When using a mouse everything works as expected! 
- I have tested this on three machines using windows7 and touchscreens, and the results were the same. 
- Sad to report that in InternetExplorer all touchinputs work as expected, even on pages failing in FireFox. 
- the addon YesScript (https://addons.mozilla.org/de/firefox/addon/yesscript/) helps as a workaround, as it allows to blacklist malfunctioning sites (i.e. automaticly deactivate JS for those), however this removes all JS-functionality.
- there are currently two threads in the support forum relating to this behaviour:
https://support.mozilla.org/de/questions/947337?esab=a&s=&r=1&as=s
https://support.mozilla.org/de/questions/948810#answer-413984
Comment 1 franz.haertl 2013-03-05 04:16:02 PST
- When using a mouse everything works as expected! 
- I have tested this on three machines using windows7 and touchscreens, and the results were the same. 
- Sad to report that in InternetExplorer all touchinputs work as expected, even on pages failing in FireFox. 
- the addon YesScript (https://addons.mozilla.org/de/firefox/addon/yesscript/) helps as a workaround, as it allows to blacklist malfunctioning sites (i.e. automaticly deactivate JS for those), however this removes all JS-functionality.
- there are currently two threads in the support forum relating to this behaviour:
https://support.mozilla.org/de/questions/947337?esab=a&s=&r=1&as=s
https://support.mozilla.org/de/questions/948810#answer-413984
Comment 2 franz.haertl 2013-03-14 00:38:46 PDT
Update: 
The problem is still there after the update to FireFox 19.0.2 and the recent Windows7 update.
Comment 3 tacitus86 2013-03-23 08:31:47 PDT
i have this issue on the Surface Pro tablet as well.
Comment 4 tacitus86 2013-03-23 08:32:42 PDT
(In reply to tacitus86 from comment #3)
> i have this issue on the Surface Pro tablet as well.

Running standard Win 8 64 and default Surface Pro hardware.
Comment 5 franz.haertl 2013-03-25 00:44:19 PDT
Support-forum user cor-el suspected a key-state-error, where FF sees some buttons as pressed. As by his suggestion I tried pressing alt, shift and ctrl-keys on the win7 onscreen-keyboard as well as an attached USB-keyboard. There was no improvement, so this should not be the problem.
Comment 6 thorstenr_42 2013-03-30 14:01:58 PDT
I've noticed this issue since the introduction of multitouch support with firefox 4 and it's still occuring with the latest nightly version.
This bug occurs with firefox runing on Windows 7 as well as on Windows 8. Im using an thinkpad x220t.
Comment 7 Pedro Sland 2013-04-08 02:16:19 PDT
I have done some investigation on this problem. I am using Windows 8, FF v20.0.

Here is a test case http://run.plnkr.co/Lvembi8qt0Z576aS/. Please can the others here report if this gives them scrolling problems.

The source is http://plnkr.co/edit/sUSoil?p=preview. Commenting out line 99 (`el.addEventListener("touchstart", handleStart, false);`) makes it work.
The test is based on https://developer.mozilla.org/samples/domref/touchevents.html.
Comment 8 Pedro Sland 2013-04-08 02:19:52 PDT
I should add that I tried this on a new profile with all extensions (the AV ones installed system-wide) and plugins disabled.
Comment 9 franz.haertl 2013-04-08 03:06:46 PDT
Thank you Pedro!
Yep, the demopage is a perfect sample: 
- scrollbars jump
- scrolling by swiping doesn't do anything
- mouse-operation works as expected
-> bug confirmed!

IE 9.0.8112.16421 (64bit) - everything works as expected
IE 9.0.8112.16421 (32bit) - everything works as expected


It doesn't surprise me actually that it's got something to do with touchevents being "optimized". I guess that the optimisation is actually aimed at smartphones, but somehow breaks firefox-compatibility with the windows-touchevent-system. Could someone owning a smartphone confirm that scrolling actually works in firefox mobile?
Comment 10 Pedro Sland 2013-04-09 03:30:52 PDT
I just tested this on FF v20.0 on Galaxy Nexus running Android v4.2.2.

Scrolling works correctly on the page and of course there is no scrollbar to test.

While touch events are used most on smartphones I can't see any reason why FF shouldn't support it on the desktop.

If someone thinks it could help I could burn a Linux live cd and see if that supports touch and it FF works correctly there.
Comment 11 franz.haertl 2013-04-09 06:15:02 PDT
Update: 
No improvement after updating to FireFox 20.0.
Comment 12 franz.haertl 2013-04-09 06:18:36 PDT
(In reply to franz.haertl from comment #11)
> Update: 
> No improvement after updating to FireFox 20.0.

That is on Windows 7 Professional 64bit
and Windows 7 Home Premium 32bit
Comment 13 Pedro Sland 2013-04-11 12:34:39 PDT
I found a bug report I'd missed before, this time searching with google. I think this is a duplicate of bug 736048.
Comment 14 franz.haertl 2013-04-12 01:26:35 PDT
It seems to be a duplicate indeed. So the problem is known for quite a while now. I know Firefox is free and all, but some confirmation that the problem is at least being worked on would be nice. I'll gladly provide any help I possibly can. The number of windows-devices with touchscreen is growing, and not being able to use major sites like google is sort of a killer, even for Firefox-enthusiasts.

Update:
No improvement after updating to 20.1, Windows 7 Professional 64bit
and Windows 7 Home Premium 32bit.
Comment 15 Blair McBride [:Unfocused] (UNAVAILABLE) 2013-04-12 02:09:40 PDT

*** This bug has been marked as a duplicate of bug 736048 ***

Note You need to log in before you can comment on or make changes to this bug.