Closed Bug 847914 Opened 7 years ago Closed 6 years ago

remove RGBImage from the SurfaceDescriptor types

Categories

(Core :: Graphics: Layers, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 966999

People

(Reporter: nical, Assigned: nical)

References

Details

RGBImage (see LayersSurfaces.ipdl) is redundant. We already have ways to pass images of various rgb formats is SurfaceDesciptors. This code duplication can be factored to simplify and reduce the layers code.

This is low priority and should be dealt with after the layers refactoring has landed.
Depends on: 842518
Blocks: 842518
No longer depends on: 842518
Depends on: 900244, 938591
This is done in the patch bug 966999
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 966999
You need to log in before you can comment on or make changes to this bug.