mozharness doesn't retry if the hg clone of hg.m.o/build/tools fails

RESOLVED DUPLICATE of bug 840305

Status

RESOLVED DUPLICATE of bug 840305
6 years ago
3 months ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozharness])

(Reporter)

Description

6 years ago
eg:
https://tbpl.mozilla.org/php/getParsedLog.php?id=20336846&tree=Mozilla-Inbound#error0

{
04:07:50     INFO - #####
04:07:50     INFO - ##### Running pull step.
04:07:50     INFO - #####
04:07:50     INFO - Changing directory to /Users/cltbld/talos-slave/test/build.
04:07:50     INFO - Setting /Users/cltbld/talos-slave/test/build/tools to http://hg.mozilla.org/build/tools.
04:07:50     INFO - Cloning http://hg.mozilla.org/build/tools to /Users/cltbld/talos-slave/test/build/tools.
04:07:50     INFO - Running command: ['hg', '--config', 'ui.merge=internal:merge', 'clone', 'http://hg.mozilla.org/build/tools', '/Users/cltbld/talos-slave/test/build/tools']
04:07:50     INFO - Copy/paste: hg --config ui.merge=internal:merge clone http://hg.mozilla.org/build/tools /Users/cltbld/talos-slave/test/build/tools

command timed out: 1200 seconds without output, attempting to kill
process killed by signal 9
program finished with exit code -1
elapsedTime=1213.977070
========= Finished '/tools/buildbot/bin/python scripts/scripts/desktop_unittest.py ...' failed (results: 2, elapsed: 20 mins, 13 secs) (at 2013-03-05 04:27:50.231100) =========
}

Expected:
1) We retry instead of timing out and failing the run
2) We don't wait 20 mins at a hung hg clone.

:-)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 840305
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
(Assignee)

Updated

3 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.