Bluetooth settings UI does not update connection status properly

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: ggrisco, Assigned: arthurcc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Whiteboard: [CR 446962])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
1. Put Motorola HX550 headset in discoverable mode
2. Scan from Settings menu and try to connect to the headset
3. Pairing goes through successfully, however no HFP connection happens

When we Initiate connection/pairing request from Device we are able to set connection with Motorola HX550 but B2G device is unable to update the status on the UI.
Successfull connection  was indicated by hci dumps and we were  able to make call through headset.

We were expecting BT connection state ("connecting/connected") below the connected device name but it was blank.
Same behavior we observed with other headset too eg: Sony DR BT 50

The following was seen in adb logs:

<<<<<<
E/GeckoConsole(  440): [JavaScript Error: "NotFoundError: Node was not found" {file: "app://settings.gaiamobile.org/js/bluetooth.js" line: 467}]
E/GeckoConsole(  440): [JavaScript Error: "NotFoundError: Node was not found" {file: "app://settings.gaiamobile.org/js/bluetooth.js" line: 467}]
E/GeckoConsole(  440): [JavaScript Error: "pairList.index[deviceAddress] is undefined" {file: "app://settings.gaiamobile.org/js/bluetooth.js" line: 562}]
E/GeckoConsole(  440): [JavaScript Error: "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "pairList.index[deviceAddress] is undefined" {file: "app://settings.gaiamobile.org/js/bluetooth.js" line: 562}]' when calling method: [nsIDOMSystemMessageCallback::handleMessage]" {file: "jar:file:///system/b2g/omni.ja!/components/SystemMessageManager.js" line: 76}]
(Reporter)

Updated

6 years ago
Severity: normal → critical
blocking-b2g: --- → tef?
blocking-b2g: tef? → tef+
Kevin, can you please find a Bluetooth owner?
Assignee: nobody → khu
Evelyn, would you work on this bug or reassign someone?
Assignee: khu → ehung
Flags: needinfo?(ehung)
PS. Should be an UI issue based on logcat.

Comment 4

6 years ago
Not sure if it's a device dependent issue, we need to test our headsets first to figure out it.

Briefly discussed with Arthur, reassign to him.
Assignee: ehung → arthur.chen
Flags: needinfo?(ehung)
Cannot reproduce with current tested devices. (Jabra wave+ and Plantronics Explorer 240). Current findings based on the code:
If defaultAdapter.getPairedDevices() returns after the event 'bluetooth-hfp-status-changed', there is a chance that pairList.index[deviceAddress] is undefined. 

As for the "NotFoundError", the reason is that the saved dom node cannot be found in the container. I still cannot find any calling path that leads to that result.
(In reply to Arthur Chen [:arthurcc] from comment #5)
> Cannot reproduce with current tested devices. (Jabra wave+ and Plantronics
> Explorer 240). Current findings based on the code:
> If defaultAdapter.getPairedDevices() returns after the event
> 'bluetooth-hfp-status-changed', there is a chance that
> pairList.index[deviceAddress] is undefined. 
> 
can anything be done base on your findings? thanks 

> As for the "NotFoundError", the reason is that the saved dom node cannot be
> found in the container. I still cannot find any calling path that leads to
> that result.
Joe, we can try to fix the race condition. However, fixing it does not help on the issue of the UI not updating. Need QA to verify the environment and devices of reproducing the bug.

Cannot reproduce with b2g18_eng (https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi-eng/2013/03/2013-03-15-07-02-20/) and mozilla central (https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-central-unagi/2013/03/2013-03-17-03-10-17/).
Keywords: qawanted
Just curious, can it be reproduced always in reporter's environment?
taipei qa, can you try and reproduce?  do you guys have a headset?
Created attachment 726909 [details]
Screenshot of successful pairing

Not seeing this using QC RIL build - see attached screenshot of successful pairing with Plantronics BT:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/406b86b4b515
Gaia   c5a8b6476f0dbc456061227a7801e56634683eb0
BuildID 20130319070203
Version 18.0
I think the bug report is from v1.0.1 though, not v1-train.
I tested this again with the same BT device using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6a00a4d8f017
Gaia   f03bc0e8647f94ab133fe813d68500061c147681
BuildID 20130311070204
Version 18.0

The first time I tried to connect it did not say "Connected." After I unpaired the device and repaired it shows "Connected" below the headset name. 

Also tried with a Jabra headset and this connected with no issues the first time.
Tony Chung, negative. But, I will try to get a device to test on it. Sorry for my negligence that I didn't notice this bug.
I can't reproduce it too.
Greg, which build were you using?  Does this bug still occur happen with a current build?
Flags: needinfo?(ggrisco)
Keywords: qawanted
(Reporter)

Comment 16

6 years ago
BuildID 20130314102722
Version 18.0

This version can pair and automatically connect to my Plantronics headset ok with the "Connected" status displayed under the device name.  However, after turning BT off then back on, device automatically re-connects (great!) but the status under the device name is blank (not so great).

I can ask for a re-test of the reported bug with the Motorola and Sony headsets and get back to you.
Flags: needinfo?(ggrisco)
(Reporter)

Updated

6 years ago
Flags: needinfo?(ggrisco)

Comment 17

6 years ago
That will be great. Thanks.
Greg, any update on the re-test of the original reporting?
In addition, is your observation in comment 16 100% reproduced?

Walter/Al, do we have other headsets to retest this in parallel? and with the scenario described in comment 16?
Flags: needinfo?(wachen)
(Reporter)

Comment 19

6 years ago
(In reply to Wayne Chang [:wchang] from comment #18)
> Greg, any update on the re-test of the original reporting?
> In addition, is your observation in comment 16 100% reproduced?
> 
> Walter/Al, do we have other headsets to retest this in parallel? and with
> the scenario described in comment 16?

Re-test confirmed that my observation in comment 16 is reproducible with other headsets.  However, I didn't get a clear answer yet on whether the original steps are reproducible.  I'm trying to get that info still.
Flags: needinfo?(ggrisco)
(Reporter)

Comment 20

6 years ago
Hi Wayne, the original steps are not reproducible.  Do you want to track the problem that I mentioned in comment 16 here?  Or would you like another bugzilla for that?
Flags: needinfo?(wchang)
Hi Greg,
Do you want to close this bug off as working for you on new build and fire another bug to track comment 16? Let's track with a new bug so people dont mix the symptoms up when reading the bug.
Thanks,
Wayne
Flags: needinfo?(wchang)
(Reporter)

Comment 22

6 years ago
Created new bug 854609 for tracking the issue in comment 16.
Marking this bug as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
clearing walter from NI for this one, adding tpe qa to new bug 854609.
Flags: needinfo?(wachen)
You need to log in before you can comment on or make changes to this bug.