Closed Bug 848411 Opened 7 years ago Closed 4 years ago

Permission database not setup correctly for b2g

Categories

(Testing :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

In bug 846090, I noticed that allowXULXBL permission isn't set for b2g mochitests.
This is working fine on desktop Firefox mochitest, afaik.
b2g reftests worked around this by setting this permission from within javascript:
http://mxr.mozilla.org/mozilla-central/source/layout/tools/reftest/b2g_start_script.js#32

However, that is not the solution, this permission setting should be possible from the python script.

automation.py setupPermissionsDatabase is located here:
http://mxr.mozilla.org/mozilla-central/source/build/automation.py.in#271
Perhaps this is all working correctly, but is permission.sqlite not used from gaia at all, but is it using a different permissions database or something?
Ok, some relevant info from bug 846090 about this:
From irc:
[22:10]	<gwagner>	mw22: the appId has to match. otherwise we don't allow any permission
[22:11]	<gwagner>	mw22: I see that you always use appId 0

my question, how can you know the appId?
[23:00]	<fabrice>	mw22: it can ba anything, but it has to match what's in the webapps.json


The permission database which is written here (for allowXULXBL):
http://mxr.mozilla.org/mozilla-central/source/testing/mozbase/mozprofile/mozprofile/permissions.py#258
So it has to add the appId of the mochitest app in order for this to work.

I tried to get something working with:
https://bug846090.bugzilla.mozilla.org/attachment.cgi?id=790182 (from bug 846090, comment 27)

In bug 846090, I added a workaround for this, that allows the allowXULXBL permission to work.
For reftests, a similar workaround was added here: http://mxr.mozilla.org/mozilla-central/source/layout/tools/reftest/b2g_start_script.js#33

These workarounds could be removed once this bug would be fixed, properly.
Summary: Setting up permission database not working for b2g mochitest? → Permission database not setup correctly for b2g
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.