Facebook Desktop Plugin causes the browser to Crash or Hang

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Matt_G, Assigned: Jack O'Connor)

Tracking

({hang})

19 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WinXP only, according to most reports][fixed in Facebook Messenger 2.1.4814.0], crash signature)

(Reporter)

Description

5 years ago
We are seeing a spike in reports of Facebook crashes and hangs in the last 24 hours. In our SUMO investigations it looks like it is related to the Facebook Desktop plugin. Info in this thread:
https://support.mozilla.org/en-US/questions/952617

Here are some verbatims from input:
https://input.mozilla.org/en-US/opinion/3612227
https://input.mozilla.org/en-US/opinion/3611953
https://input.mozilla.org/en-US/opinion/3611947
https://input.mozilla.org/en-US/opinion/3611350
https://input.mozilla.org/en-US/opinion/3611147

Seems to happen right when they land on the page. Reports are spread across all operating systems. We are in the process of doing more 1 on 1 outreach on SUMO to confirm.

Comment 1

5 years ago
It's correlated to two events:
* A new version of Facebook Messenger for Mobile was released on March 6th: https://play.google.com/store/apps/details?id=com.facebook.orca (2.3.1-release on Android) and https://itunes.apple.com/in/app/facebook-messenger/id454638411?mt=8 (2.3 on iOS)
* Bugs fixed in Facebook on March 6th: http://developers.facebook.com/blog/post/2013/03/06/platform-updates--operation-developer-love/
Severity: normal → critical
Component: General → Plug-ins
Keywords: hang
Product: Firefox → Core
Priority: -- → P2
Summary: Facebook Destktop Plugin causes the browser to Crash or Hang → Facebook Desktop Plugin causes the browser to Crash or Hang

Updated

5 years ago
Duplicate of this bug: 848774

Comment 3

5 years ago
What is the FB desktop plugin? Is it actually a browser plugin?
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> What is the FB desktop plugin? Is it actually a browser plugin?

Apparently it comes with Facebook Desktop, an out-of-browser desktop integration of Facebook chat notifications etc.
The plugin is npfbdesktopplugin.dll, probably providing the connection with the desktop integration.
(In reply to Georg Fritzsche [:gfritzsche] [away Mar 8 - Mar 17] from comment #4)
> (In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> > What is the FB desktop plugin? Is it actually a browser plugin?
> 
> Apparently it comes with Facebook Desktop

Or Facebook Messenger; it's not entirely clear if those are two separate products.
(Assignee)

Comment 6

5 years ago
That plugin is part of Facebook Messenger for Windows. "Facebook Desktop" isn't an official name, but it's the same thing. Facebook Messenger for Android and iOS are unrelated products (slightly confusing), but the desktop app also pushed out a new version starting on March 4. This could be related, and I'm going to try to repro.

-- Jack O'Connor, Facebook Desktop team
(Assignee)

Comment 7

5 years ago
I'm not able to repro the hang myself on Win7 or Win8 in Firefox 19. I see that the bug report is on Windows XP, so I'm going to try to get an XP machine to test. If anyone else wants to try to repro, you can download the desktop app here: https://www.facebook.com/about/messenger

To confirm that the plugin is working in any given page, you can run the following JS snippet and look for it to return non-null:
    require("FBDesktopPlugin").isAppRunning()

The reporter mentioned that he was able to load Facebook in Chrome, but Chrome uses the same Netscape Plugin API that Firefox does, so I'm not sure how to explain that.
(Assignee)

Comment 8

5 years ago
Successful repro in the "XP Mode" VM under Win7. Firefox hangs as reported, Chrome shows a plugin crashed butterbar, and IE 8 just fails to load the plugin at all.

The source of the crash looks like a slightly embarrassing build configuration issue that only affects Windows XP: http://blogs.msdn.com/b/vcblog/archive/2012/10/08/10357555.aspx I have a fix ready, and I will push it out as soon as I can.

Updated

5 years ago
Keywords: qawanted
OS: All → Windows XP
Hardware: All → x86

Comment 9

5 years ago
Jack, excellent! Could somebody (in your QA team or ours) spend a minute figuring out why our plugin hang reporter isn't triggering in this case? It's probably sufficient to hang Firefox and then run this tool http://benjamin.smedbergs.us/crashfirefox.exe to actually force Firefox to crash and submit a crash report.
Assignee: nobody → oconnor663
Keywords: qawanted
Whiteboard: WinXP only, according to most reports
(Assignee)

Comment 10

5 years ago
I've just submitted a crash report from that state. It contains this bug number, so hopefully you can search for it?

We will start rolling out the fix today, and a majority of users should get it within a few days. The fixed MSI is here if you want to play with it: http://dragon.ak.fbcdn.net/cfs-ak-ash3/676500/39/FacebookMessenger_v2.1.4814.0.msi
(Assignee)

Comment 11

5 years ago
And if you want to play with the broken version to see what the browser is doing, you can get it here: http://dragon.ak.fbcdn.net/cfs-ak-ash3/676400/571/FacebookMessenger_v2.1.4801.0.msi

Comment 12

5 years ago
Can you look in your about:crashes and give me the crash report ID/link?

Updated

5 years ago
Crash Signature: [@ @0x0 | mozilla::plugins::BrowserStreamChild::Deliver() ]
Whiteboard: WinXP only, according to most reports → [WinXP only, according to most reports][fixed in Facebook Messenger 2.1.4814.0]
Considering comment 13, do you still need QA help or can the "qawanted" keyword be removed?

Comment 15

5 years ago
http://crash-stats.mozilla.com/report/index/04088079-1a53-4cca-8adf-0612f2130308 was the relevant crash report. We appear to be under mozilla::ipc::GeckoChildProcessHost::SyncLaunch and *should* be timing out after 45 seconds. Is that 45-second timeout what people are seeing, or does the browser never recover?
(Assignee)

Comment 16

5 years ago
I had been seeing some "stop plugin?" dialogs before, which might've come after 45 seconds. When I tried the failing plugin again just now in FF19 on XP, I found that Facebook would totally hang the browser for 45 seconds, followed by maybe a second of UI updating/scrolling/whatever. That repeated at least three times and didn't show any signs of stopping. If your QA team wants to test the broken plugin, you can try the MSI in comment 11.
I was able to reproduce this issue as suggested, with the MSI from comment 11 and both Firefox 19.0 and Firefox 19.0.2. Firefox did indeed hang, and the Unresponsive Script dialog appeared, but I didn't get any crash.

Couldn't reproduce with the latest Nightly, build ID: 20130312031046.
Couldn't reproduce with the latest Aurora, build ID: 20130312042013.
Couldn't reproduce with the latest Beta, Firefox 20 beta 4, build ID: 20130307075451.

Comment 18

5 years ago
(In reply to Manuela Muntean [:Manuela] [QA] from comment #17)
> I didn't get any crash.
See comment 9 to transform the hang in crash.
Here is the crash that I got, after following comment 9, with Firefox 19.0.2 on a XP 32-bit machine: https://crash-stats.mozilla.com/report/index/bp-f2ac1ba7-616b-4388-9d6a-7341d2130313

Updated

5 years ago
Priority: P2 → P3

Updated

5 years ago
Crash Signature: [@ @0x0 | mozilla::plugins::BrowserStreamChild::Deliver() ] → [@ @0x0 | mozilla::plugins::BrowserStreamChild::Deliver() ] [@ @0x0 ]
From what i understand we can't track this via crash-stats - Matt, has this still been coming up after the fix was pushed out?
Flags: needinfo?(mgrimes)
(Reporter)

Comment 21

5 years ago
Things died off quickly after the update was pushed. We aren't seeing any traffic on it in SUMO or Input.
Flags: needinfo?(mgrimes)
Thanks Matt, closing this for now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.