Last Comment Bug 848685 - When many flags are set for a patch attachment, the "Mozilla" theme in b.m.o shows them in a single line
: When many flags are set for a patch attachment, the "Mozilla" theme in b.m.o ...
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: Sandstone/Mozilla Skin (show other bugs)
: Production
: All All
: -- normal (vote)
: ---
Assigned To: Mark Côté [:mcote]
:
:
Mentors:
: 849467 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-06 23:31 PST by Gary Kwong [:gkw] [:nth10sd]
Modified: 2013-06-30 22:29 PDT (History)
6 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot (25.74 KB, image/png)
2013-03-06 23:31 PST, Gary Kwong [:gkw] [:nth10sd]
no flags Details
Fix line breaks in attachment flags and group checkboxes (550 bytes, patch)
2013-06-27 19:08 PDT, Mark Côté [:mcote]
glob: review-
Details | Diff | Splinter Review
Fix line breaks in attachment flags and group checkboxes, v2 (337 bytes, patch)
2013-06-28 09:53 PDT, Mark Côté [:mcote]
glob: review+
Details | Diff | Splinter Review

Description Gary Kwong [:gkw] [:nth10sd] 2013-03-06 23:31:46 PST
Created attachment 722094 [details]
screenshot

When many flags are set for a patch attachment, the "Mozilla" theme in b.m.o shows them in a single line, so this results in a really long line. See screenshot.

The default Dusk theme does not exhibit this behaviour.
Comment 1 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-03-06 23:32:37 PST
not a regression, as the mozilla skin is new.
Comment 2 Mike Connor [:mconnor] 2013-03-07 08:01:16 PST
Also true of group checkboxes, probably a related/similar bug. :)
Comment 3 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-03-10 22:06:29 PDT
*** Bug 849467 has been marked as a duplicate of this bug. ***
Comment 4 Mark Côté [:mcote] 2013-06-27 19:08:19 PDT
Created attachment 768705 [details] [diff] [review]
Fix line breaks in attachment flags and group checkboxes

So br elements in the entire #bz_big_form_parts table are set to "display: none". I'm not sure why, but I presume it's for a good reason, so this patch just undoes that for the attachment flags and group checkboxes.

The attachments table is still a lot wider than in the Dusk skin; I'm not sure if that was done on purpose or not.
Comment 5 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-06-28 00:04:40 PDT
Comment on attachment 768705 [details] [diff] [review]
Fix line breaks in attachment flags and group checkboxes

> So br elements in the entire #bz_big_form_parts table are set to "display:
> none". I'm not sure why, but I presume it's for a good reason, so this patch
> just undoes that for the attachment flags and group checkboxes.

i don't see any good reason for that, so instead i would prefer for that clause to be removed.

the only other <br> in #bz_big_form_parts is after the comment textarea, and i don't see any differences display-wise with that br hidden.
Comment 6 Mark Côté [:mcote] 2013-06-28 09:53:54 PDT
Created attachment 769007 [details] [diff] [review]
Fix line breaks in attachment flags and group checkboxes, v2

Sounds good.
Comment 7 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-06-30 22:27:52 PDT
Comment on attachment 769007 [details] [diff] [review]
Fix line breaks in attachment flags and group checkboxes, v2

r=glob
Comment 8 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-06-30 22:29:30 PDT
thanks mark!

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified skins/contrib/Mozilla/global.css
Committed revision 8862.

Note You need to log in before you can comment on or make changes to this bug.