Is inposible install an app from everyting.me

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Everything.me
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: rafael.marquez, Assigned: Evyatar 'Tron' Amitay (everything.me))

Tracking

unspecified
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Reporter)

Description

5 years ago
*Procedure
1. lunch everyting.me
2. Open a category
3. Hold on an app icon to install it

*Expected Result
Install screen is launched

*Actual Result
if I hold on an app icon, the device does not launch the screen to install the app


Device: Unagi
Version: Gecko-0aa4d54.Gaia-77fb74e
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
Summary: Is inposible install an app from everyting.me → Is impossible install an app from everyting.me
With latest build of gecko

E/GeckoConsole(  576): Content JS LOG at app://homescreen.gaiamobile.org/everything.me/js/helpers/Utils.js:60 in log: [11:35:03:032 EVME]: CB Error! Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWindowWatcher.openWindow]
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Summary: Is impossible install an app from everyting.me → Is inposible install an app from everyting.me
(Reporter)

Updated

5 years ago
Summary: Is inposible install an app from everyting.me → Is impossible install an app from everything.me
Summary: Is impossible install an app from everything.me → Is inposible install an app from everyting.me
I have detected that window.alert and window.confirm methods crash in that build
Could it be related to bug 844530?
Assignee: crdlc → nobody
blocking-b2g: tef? → tef+
Evyatar, are you the best owner here?
Assignee: nobody → evyatar
Flags: needinfo?(evyatar)
Yeah, I'm the contact for this.

I'll check it out, if window.alert and window.confirm indeed crash then it's most likely a gaia issue, not e.me. I'll check it and report back.
Flags: needinfo?(evyatar)
I'm seeing everything correctly, updated to gecko-d28b134.

Long tap on app
Confirm "Add {APP NAME} to Home Screen?"
Tap "OK"
Banner "{APP NAME}} added to Home Screen"

Cristian- how can I reproduce? Do you think it's an issue with our code, or is it gaia?
Flags: needinfo?(crdlc)
No, the problem was from Gecko, window.confirm failed in some builds. If you cannot reproduce this problem with latest builds, please close this one like worksforme
Flags: needinfo?(crdlc)
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 847935
You need to log in before you can comment on or make changes to this bug.