FF doesn't render SVG on site correctly due to poor user agent sniffing

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: hwine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 722974 [details]
Screenshot_2013-03-08_14_53.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

went to http://blockdiag.com/en/seqdiag/demo.html with FF 19 (release)


Actual results:

The "diagram output" area (lower right) is clipped, and not displayed full width. "playing" with inspector, it appears to be clipping in the SVG display, as the inspector outline shows the container to be full width. Screenshot attached showing svg container. Selecting the clipped (rightmost) rectangle with the inspector shows it does extend beyond the clip boundary.


Expected results:

The entire output diagram should be shown, as it is with Chrome (v25.0.1364.160)

Comment 1

6 years ago
Regression range:
m-c
good=2012-03-03
bad=2012-03-04
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=343ec916dfd5&tochange=baec1efc87a4
Component: ImageLib → SVG
Keywords: regression
Version: 19 Branch → 13 Branch

Comment 2

6 years ago
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d43c3e308c82
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120302 Firefox/13.0a1 ID:20120303052207
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7c62688f88fa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1 ID:20120303053807
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d43c3e308c82&tochange=7c62688f88fa

Triggered by:  Bug 687579


So, I think this is the site problem.

The following user agent sniffing fails.
http://blockdiag.com/en/_static/interactive.js:
>        is_webkit = !document.uniqueID && !window.opera && !window.globalStorage && window.localStorage
Assignee: nobody → english-us
Component: SVG → English US
Keywords: regression
OS: Mac OS X → All
Product: Core → Tech Evangelism
Hardware: x86 → All
Version: 13 Branch → Trunk

Updated

6 years ago
Summary: FF doesn't render SVG on site correctly → FF doesn't render SVG on site correctly due to poor user agent sniffing

Comment 3

6 years ago
Website author emailed.
http://blockdiag.com/en/#resources
The entire diagram is shown
Thanks Loic.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.