OOM crash in org.mozilla.gecko.gfx.JavaPanZoomController.startAnimationTimer when zooming into map on osm.org website

RESOLVED WORKSFORME

Status

()

Firefox for Android
Toolbar
--
critical
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: martin, Unassigned)

Tracking

({crash, reproducible})

Trunk
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox19 wontfix, firefox20 wontfix, firefox21 wontfix, firefox22 wontfix, firefox23 affected)

Details

(Whiteboard: [native-crash], crash signature, URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Android; Mobile; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20130307022932

Steps to reproduce:

Go to http://osm.org website and fast-zoom into the map while tiles are still loading.


Actual results:

FF for Android 18.0.2 crashes and Android Desktop icons are reloading. So 'main process' of Android seems to be crashing too. Device is a Samsung Galaxy Nexus with Android 4.2.2. Problem is persistent and can easily be reproduced.


Expected results:

No crash, of course. Zooming into the Openstreetmap should work.
(Reporter)

Comment 1

5 years ago
Sorry - mistyped. Version of FF is of course latest (19.0.2).

Regards

Martin
(Reporter)

Updated

5 years ago
Version: Firefox 18 → Firefox 19

Comment 2

5 years ago
Please provide the crash ID from the about:crashes page and a logcat as an attachment.
Severity: normal → critical
Flags: needinfo?(bugs.m1)
Keywords: crash, stackwanted
Hardware: Other → ARM
Whiteboard: [native-crash]
(Reporter)

Comment 3

5 years ago
There is no crash ID - seems rather an android crash to me. See logcat attached.
Flags: needinfo?(bugs.m1)
(Reporter)

Comment 4

5 years ago
Created attachment 723124 [details]
Logcat of the relevant crash data
Created attachment 723128 [details]
LG Nexus 4 (Crash log-cat)

I can reproduce this on my LG Nexus 4 (Android 4.2.2), Nightly (03.09)

W/Adreno200-GSL(14539): <sharedmem_gpumem_alloc:991>: sharedmem_gpumem_alloc: mmap failed errno 12 Out of memory

bp-9a3ac1fc-9b0e-4943-a1fb-9af7c2130309

https://crash-stats.mozilla.com/report/index/bp-9a3ac1fc-9b0e-4943-a1fb-9af7c2130309

Dupe of bug 756655.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 756655
Actually this crashes in different areas since it's an out of memory condition

Another with the same steps:https://crash-stats.mozilla.com/report/index/bp-24be693a-49c0-42f1-aec3-bcf452130309 bp-24be693a-49c0-42f1-aec3-bcf452130309
Status: RESOLVED → REOPENED
status-firefox19: --- → affected
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → affected
Ever confirmed: true
Resolution: DUPLICATE → ---
Version: Firefox 19 → Trunk
java.lang.OutOfMemoryError: thread creation failed
	at java.lang.VMThread.create(Native Method)
	at java.lang.Thread.start(Thread.java:1050)
	at java.util.Timer$TimerImpl.<init>(Timer.java:192)
	at java.util.Timer.<init>(Timer.java:367)
	at java.util.Timer.<init>(Timer.java:378)
	at org.mozilla.gecko.gfx.JavaPanZoomController.startAnimationTimer(JavaPanZoomController.java:673)
	at org.mozilla.gecko.gfx.JavaPanZoomController.fling(JavaPanZoomController.java:638)
	at org.mozilla.gecko.gfx.JavaPanZoomController.handleTouchEnd(JavaPanZoomController.java:467)
	at org.mozilla.gecko.gfx.JavaPanZoomController.handleEvent(JavaPanZoomController.java:275)
	at org.mozilla.gecko.gfx.TouchEventHandler.dispatchEvent(TouchEventHandler.java:235)
	at org.mozilla.gecko.gfx.TouchEventHandler.handleEvent(TouchEventHandler.java:181)
	at org.mozilla.gecko.gfx.JavaPanZoomController.onTouchEvent(JavaPanZoomController.java:268)
	at org.mozilla.gecko.gfx.LayerView.onTouchEvent(LayerView.java:151)


STR:

http://osm.org, conduct multiple pinch-zooms inwards and outwards, eventual OOM
Keywords: reproducible
Created attachment 723129 [details]
LG Nexus 4 (Second crash log-cat)

Updated

5 years ago
Keywords: stackwanted

Updated

5 years ago
Crash Signature: [@ java.lang.OutOfMemoryError: thread creation failed at java.lang.VMThread.create(Native Method) ]
Summary: crash when zooming into map on osm.org website → OOM crash in org.mozilla.gecko.gfx.JavaPanZoomController.startAnimationTimer when zooming into map on osm.org website
(Reporter)

Comment 10

5 years ago
FF version 23.0 affected as well. This really is an annoying bug!
status-firefox23: --- → ?
status-firefox19: affected → wontfix
status-firefox20: affected → wontfix
status-firefox21: affected → wontfix
status-firefox22: affected → wontfix
status-firefox23: ? → affected
I believe this should be fixed by bug 711959. At least the symptoms in comment 8 should go away.
Depends on: 711959
Does this still happen? If the crash happens, do you still see the stack in comment 8 anywhere? If not then this should be moved to some other component as a more general OOM crash.
Keywords: qawanted
(Reporter)

Comment 13

5 years ago
Crashes don't happen anymore. Seems to be fixed. Thanks a lot!
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.