Korean and Simplified Chinese font uninstallable

RESOLVED FIXED in Future

Status

()

Core
Internationalization
--
trivial
RESOLVED FIXED
17 years ago
11 years ago

People

(Reporter: Edwin Martin, Assigned: Jungshik Shin)

Tracking

({intl})

Trunk
Future
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When opening a page with an Korean or Simplified Chinese text, dialog boxes
pop up to download executables:

komondo.exe for Korean font
scmondo.exe for Simplified Chinese font

When running these programs, a alert pops up with the text:

"Microsoft Global IME 5.02 for Korean
This version of Global IME cannot be installed on this version of Windows."

or

"Microsoft Global IME 5.02 for Chinese (Simplified)
This version of Global IME cannot be installed on this version of Windows."

Or: I can't view Korean/Simplified Chinese text with Mozilla (in Windows 2000).

See the URL for a page containing these languages

Comment 1

17 years ago
Reassign to yokoyama, cc to ftang.
Assignee: nhotta → yokoyama
Keywords: intl

Comment 2

17 years ago
reassign to ftang and mark moz0.9.3.
This make me think that we probably should keep the redirect page in server side 
instead of put into the client so we can address this type of problem easier. 
Assignee: yokoyama → ftang
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → mozilla0.9.3

Comment 3

17 years ago
Having the redirect server side solves that issue. We can always point to where
we need to from the server. Don't see how that has to do, with having local
dialogue.

Comment 4

17 years ago
Changing QA contact to teruko for now.
QA Contact: andreasb → teruko

Comment 5

17 years ago
These bits do not work on W2K.  The problem is the Global IME.  Asian input
is built into W2K.  The fonts are probably OK.

We could detect if W2K is running and pop up a dialog to tell the user to
install from the W2K CD...

Comment 6

17 years ago
Changed QA contact to ylong@netscape.com.
QA Contact: teruko → ylong

Comment 7

17 years ago
ok, now the font download dialog box won't show up in win2k
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
What does show up?  Do we get a dialog to tell the user to install fonts from
the W2K CD?

Comment 9

17 years ago
Since this is related to the font download, I changed QA contact to 
teruko@netscape.com.
QA Contact: ylong → teruko

Comment 10

17 years ago
In Win2k US, the small dialog will show up in short time with 7-11 branch build.
This warining dialog problem is in bug 87945.  

Since Font download is downloading the Global IME, this problem occurs.  

I just reopen this since this is not solved.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

17 years ago
Font Download Bug Fixin'. Pls TM0.9.4

Updated

17 years ago
Keywords: nsbeta1

Comment 12

17 years ago
Doesn't look like this is getting fixed before the freeze tonight.
Pushing out a milestone, per Jaime.  Please correct if I'm mistaken.
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Updated

16 years ago
Keywords: nsBranch

Comment 13

16 years ago
move to moz 0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Updated

16 years ago
Status: REOPENED → ASSIGNED

Comment 14

16 years ago
nsbranch- since Frank moved it to 0.9.5
Keywords: nsbranch → nsbranch-

Comment 15

16 years ago
future it.
Severity: normal → trivial
Target Milestone: mozilla0.9.5 → Future

Updated

16 years ago
Blocks: 104166

Updated

16 years ago
Blocks: 107067

Updated

16 years ago
Keywords: nsbranch-

Comment 16

13 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago13 years ago
Resolution: --- → WONTFIX

Comment 17

13 years ago
Mass Reassign Please excuse the spam
Assignee: ftang → nobody

Comment 18

13 years ago
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 19

13 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
(Assignee)

Comment 20

11 years ago
this was 'fixed' by removing the font download dialog a while ago.
Status: NEW → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.