PDF getting corrupted on download using Save page

RESOLVED DUPLICATE of bug 738952

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 738952
5 years ago
5 years ago

People

(Reporter: info621group07, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

I am experiencing an issue with FF 19.0.2 on win 7

1) Go to any web page with pdf  For example, http://www.planetpdf.com/planetpdf/pdfs/free_ebooks/A_Christmas_Carol_NT.pdf
2) Do Save page As from FF menu and download save pdf file ( I am not using save in built in PDF.js viewer)
3) Open pdf file,it's corrupted


Actual results:

PDF file got  corrupted on saving.


Expected results:

Pdf file should have been saved properly . So that I can view it in pdf viewer. Both save page us and save option PDF.js viewer should work the same way for pdf files.
Will be fixed in Firefox 20+.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738952
You need to log in before you can comment on or make changes to this bug.