If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mozilla/intl/uconv/ucvja/IBMNEC.map removed during "make distclean"

RESOLVED FIXED in mozilla0.9.3

Status

SeaMonkey
Build Config
P3
normal
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: pocemit, Assigned: cls)

Tracking

Trunk
mozilla0.9.3
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [ja] (X11; U; Linux 2.4.4 i586; Nav)
BuildID:    20010610

When doing a "make distclean" and building from outside the source directory,
this file is missing.

Reproducible: Always
Steps to Reproduce:
1.make distclean
2.rebuild

Actual Results:  error:
/tmp/mozilla/intl/uconv/ucvja/nsJapaneseToUnicode.cpp:39: IBMNEC.map: No such
file or directory
/tmp/mozilla/intl/uconv/ucvja/nsJapaneseToUnicode.cpp: In method `nsresult
nsShiftJISToUnicode::Convert(const char *, PRInt32 *, PRUnichar *, PRInt32 *)':
/tmp/mozilla/intl/uconv/ucvja/nsJapaneseToUnicode.cpp:105: warning: `PRUint16
ibmnec' might be used uninitialized in this function
make[3]: *** [nsJapaneseToUnicode.o] Error 1


Expected Results:  well, it should just work
(Assignee)

Comment 1

17 years ago
I can't reproduce this with an objdir build but doing a distclean in the srcdir
will remove the .map file.  Here's a patch.
(Assignee)

Comment 2

17 years ago
Created attachment 37932 [details] [diff] [review]
Only remove specific $(PROGRAM:.exe=.map) file.

Updated

17 years ago
Priority: -- → P3
Target Milestone: --- → mozilla0.9.3

Comment 3

17 years ago
r=jag

Comment 4

17 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
Blocks: 83989
(Assignee)

Comment 5

17 years ago
Patch has been checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.