JavaScript error in pageInfo.js with broken image

RESOLVED FIXED in seamonkey2.19

Status

SeaMonkey
Page Info
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

unspecified
seamonkey2.19

SeaMonkey Tracking Flags

(seamonkey2.16 affected, seamonkey2.17 fixed, seamonkey2.18 fixed, seamonkey2.19 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Bug 504041 made it necessary for bug 811904 to change its animated image detection. However the new code sometimes throws exceptions for broken images. It seems to be "OK" for broken data: "images" but not broken http: "images".

Steps to reproduce problem:
1. Load a page that contains a broken image
2. Find the image in Page Info
3. Note that the image properties do not update when the image is selected
(Assignee)

Comment 1

4 years ago
Created attachment 723722 [details] [diff] [review]
Proposed patch

The documentation for the animated property says that it might throw if the decode isn't complete, thus the extra check.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #723722 - Flags: review?(philip.chee)

Comment 2

4 years ago
Comment on attachment 723722 [details] [diff] [review]
Proposed patch

Tested with data:text/html,<img src=http://doesnotexist.local/><img src=about:logo><img src=data:,>

r=me
Attachment #723722 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 3

4 years ago
Pushed comm-central changeset ce090c5eb94b.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

4 years ago
Comment on attachment 723722 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 811904
User impact if declined: Page info image tab does not update correctly
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #723722 - Flags: approval-comm-beta?
Attachment #723722 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #723722 - Flags: approval-comm-beta?
Attachment #723722 - Flags: approval-comm-beta+
Attachment #723722 - Flags: approval-comm-aurora?
Attachment #723722 - Flags: approval-comm-aurora+

Updated

4 years ago
Target Milestone: --- → seamonkey2.19

Comment 5

4 years ago
Pushed to branches:
http://hg.mozilla.org/releases/comm-aurora/rev/f28e11fb00de
http://hg.mozilla.org/releases/comm-beta/rev/58816ab28194
status-seamonkey2.17: affected → fixed
status-seamonkey2.18: affected → fixed
status-seamonkey2.19: affected → fixed
You need to log in before you can comment on or make changes to this bug.