Closed Bug 850209 Opened 7 years ago Closed 7 years ago

Support hardware decoding of h.264 in <video> element in Firefox OS browser

Categories

(Core :: Audio/Video, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 803471

People

(Reporter: lmandel, Unassigned)

Details

As detailed in bug 837236 comment 20, hardware decoding support has been disabled for the browser <video> element. We need to figure out how to safely reenable hardware decoding support for the browser's <video> element to enable Web video.
Component: Gaia::Browser → Video/Audio
Product: Boot2Gecko → Core
Version: unspecified → Trunk
This is what bug 803471 solves if I'm not mistaken.
Summary: Support h.264 in <video> element → Support hardware decoding of h.264 in <video> element in Firefox OS browser
(In reply to Chris Double (:doublec) from comment #1)
> This is what bug 803471 solves if I'm not mistaken.

So what's left to be implemented here then?
Hardware decoding has been disabled as per bug 837236. We need to implement a safe way to reenable it.
See bug 803471 comment 119 which notes that it allows playing h.264 using the hardware codec in the browser.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 837236
Duplicate of bug: 803471
You need to log in before you can comment on or make changes to this bug.