Recent Birch browser-chrome bustage after bug 844561

RESOLVED FIXED

Status

()

Firefox
Private Browsing
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Away for a while, Assigned: jdm)

Tracking

20 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Bug 844561 broke birch:

https://tbpl.mozilla.org/php/getParsedLog.php?id=20553594&tree=Birch&full=1
(Reporter)

Updated

5 years ago
Version: unspecified → 20 Branch
(Assignee)

Comment 1

5 years ago
Created attachment 724096 [details] [diff] [review]
Hide a per-window private browsing test behind the build-time define, and update non-private browsing code to account for per-window changes.
Attachment #724096 - Flags: review?(ehsan)
(Assignee)

Updated

5 years ago
Assignee: nobody → josh
(Reporter)

Updated

5 years ago
Attachment #724096 - Flags: review?(ehsan) → review+
(Assignee)

Comment 2

5 years ago
Comment on attachment 724096 [details] [diff] [review]
Hide a per-window private browsing test behind the build-time define, and update non-private browsing code to account for per-window changes.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 844561 and 842290
User impact if declined: None. This fixes perma-orange on the birch branch which is tracking beta with per-window private browsing disabled.
Testing completed (on m-c, etc.): Local testing.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #724096 - Flags: approval-mozilla-beta?
Attachment #724096 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/f4eec7b147d3
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.