work - add full screen video element to html5 video controls

RESOLVED FIXED in Firefox 23

Status

Firefox for Metro
General
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: juanb, Assigned: bbondy)

Tracking

unspecified
Firefox 23
All
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Tested on 2013-03-12 on nightly built from http://hg.mozilla.org/mozilla-central/rev/7433bc4545c9

While regression testing 801183, I found myself wanting a fullscreen video control in the html5 video I tried.

Steps:
1. Go to http://clips.vorwaerts-gmbh.de/big_buck_bunny.ogv
2. Try to fullscreen the video

Expected: Some control to fullscreen the video playback

Actual: No such control element.
(Reporter)

Updated

5 years ago
Priority: -- → P2
Whiteboard: feature=work
(Reporter)

Updated

5 years ago
Whiteboard: feature=work → feature=work DUPEME

Updated

5 years ago
Blocks: 841214

Updated

5 years ago
Priority: P2 → P3

Comment 1

5 years ago
It is important to get full screen for HTML video in these controls because we won't have Flash support and the video tag is going to be the primary video experience on Metro.  Also, is this bug materially different from bug 842130?

Jared, any change you have some cycles to help us with this?
Blocks: 842639
No longer blocks: 841214
Priority: P3 → P2
Hardware: x86_64 → All
Whiteboard: feature=work DUPEME → feature=work
Flags: needinfo?(jAwS)
(Assignee)

Comment 2

5 years ago
Should we make the html5 video control the same as Desktop Firefox?
OS: Windows 8 → Windows 8 Metro
(In reply to Brian R. Bondy [:bbondy] from comment #2)
> Should we make the html5 video control the same as Desktop Firefox?

I haven't gotten the chance to look yet (it's on my todo list), but I think metro uses mobile's video controls. Mobile and desktop should have a fullscreen button already in the video controls, so something must not be showing it.

I'll try to look into this later today.
Flags: needinfo?(jAwS)
Flags: needinfo?(jAwS)

Comment 4

5 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #2)
> Should we make the html5 video control the same as Desktop Firefox?

Are our desktop controls touch friendly? If so, let's use them. If not, let's figure out how to augment what we have that is touch friendly.
(Assignee)

Comment 5

5 years ago
Probably not 'as' touch friendly. OK.
(Assignee)

Comment 6

5 years ago
Created attachment 730349 [details]
Screenshot of Metro video controls
(In reply to Brian R. Bondy [:bbondy] from comment #6)
> Created attachment 730349 [details]
> Screenshot of Metro video controls

Thanks! I was just firing up my VM. Those are the touch controls, designed to be touch-friendly.

Ok, this is the problem here:
http://mxr.mozilla.org/mozilla-central/source/browser/metro/theme/touchcontrols.css#56

You can see what b2g did: http://mxr.mozilla.org/mozilla-central/source/b2g/chrome/content/touchcontrols.css#30

B2G has graphics for it, but they might be slightly different (they are newer though).
Flags: needinfo?(jAwS)
BTW, I don't think I'll have time to help with fixing this bug. Hopefully comment #7 is enough of a guide though. I'll try to respond to questions though.
(Assignee)

Comment 9

5 years ago
Thanks for the info Jared!
(Assignee)

Updated

5 years ago
Duplicate of this bug: 842130
(Assignee)

Comment 11

5 years ago
Created attachment 730863 [details] [diff] [review]
Patch v1.

Basically as per your suggestions in the other dupe bug and Jared's suggestion here I just made the css consistent with B2G and everything worked.
Assignee: nobody → netzen
Attachment #730863 - Flags: review?(mbrubeck)
(Assignee)

Comment 12

5 years ago
*and added the 2 missing images and modified the image paths but that's it.
Comment on attachment 730863 [details] [diff] [review]
Patch v1.

I'm also following bug 704229 which should allow us to share all this code with Fennec and B2G.
Attachment #730863 - Flags: review?(mbrubeck) → review+

Comment 14

5 years ago
We still have all the xul fennec fullscreen code sitting in the repo. Deciding what to do with that was bug 842130. If we're going to dupe over, we'll need to figure out what we plan to do with all of this code here.

http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/content/video.js
http://mxr.mozilla.org/mozilla-central/source/browser/metro/modules/video.jsm
http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/content/pages/fullscreen-video.xhtml
(Assignee)

Comment 15

5 years ago
OK I'll re-open it for that.
(Assignee)

Comment 17

5 years ago
Backout for potential bustage (on some slaves but not others :S)
https://hg.mozilla.org/integration/mozilla-inbound/rev/088d73e55949
(Assignee)

Comment 18

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8b35998de0fe
Target Milestone: Firefox 22 → Firefox 23
https://hg.mozilla.org/mozilla-central/rev/8b35998de0fe
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.