Closed Bug 850489 Opened 9 years ago Closed 9 years ago

Settings page background switches between blue and white on Nexus S

Categories

(Firefox for Android Graveyard :: Theme and Visual Design, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox21 unaffected, firefox22 fixed, firefox23 fixed)

RESOLVED FIXED
Firefox 23
Tracking Status
firefox21 --- unaffected
firefox22 --- fixed
firefox23 --- fixed

People

(Reporter: Margaret, Assigned: sriram)

References

Details

Attachments

(1 file, 1 obsolete file)

This seems like a regression from bug 846396.
Saw this today too testing a bunch of Gingerbread Alcatel phones
Attached patch Patch (obsolete) — Splinter Review
This removes the cache color hint for settings screen. That way the list view won't have a problem (tested it on a Nexus S).
Attachment #732557 - Flags: review?(mark.finkle)
Why can't we set the cache color hint to the right thing (@color/background_normal)?
Comment on attachment 732557 [details] [diff] [review]
Patch

Waiting for a reply to Wes' question before r+
Flags: needinfo?(sriram)
Attached patch PatchSplinter Review
That works.
Attachment #732557 - Attachment is obsolete: true
Attachment #732557 - Flags: review?(mark.finkle)
Attachment #736546 - Flags: review?(mark.finkle)
Flags: needinfo?(sriram)
Attachment #736546 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/cfabb78fc101
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Comment on attachment 736546 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Strange flashing
Testing completed (on m-c, etc.): Landed and works
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #736546 - Flags: approval-mozilla-aurora?
regressed by bug 846396, which is on aurora
Duplicate of this bug: 865932
Attachment #736546 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This doesn't apply cleanly to Aurora. Please provide a rebased patch or uplift yourself.
(In reply to Ryan VanderMeulen [:RyanVM] from comment #11)
> This doesn't apply cleanly to Aurora. Please provide a rebased patch or
> uplift yourself.

Brian - Can you handle this since Sriram is PTO?
Flags: needinfo?(bnicholson)
I don't see this issue on beta.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.