The stack trace breadcrumbs context menu is ugly on windows.

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
6 years ago
3 months ago

People

(Reporter: Optimizer, Unassigned)

Tracking

Trunk
All
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 724303 [details]
ugly context menu.

The padding, boldness and border is missing.
(Reporter)

Comment 1

6 years ago
Well, it is bold, but the difference is hard to see.
Hardware: x86_64 → All
Summary: The stack trace breadcrumbs conetxt menu is ugly on windows. → The stack trace breadcrumbs context menu is ugly on windows.
Version: unspecified → Trunk
Priority: -- → P3
Whiteboard: [good-first-bugs][lang=css][mentor=Optimizer]
I would like to take this!
(In reply to Joshua Smith [:joshua-s] from comment #2)
> I would like to take this!

That's wonderful, thanks!
Assignee: nobody → joshua-smith
Status: NEW → ASSIGNED
Oh no, this bug is in Windows 7.

I only have XP and Mac, so it doesn't show the issue.  Sorry guys :(
Assignee: joshua-smith → nobody

Comment 5

5 years ago
Hi I am interested in working on this bug,but it's my first time to work on with debug,can anybody guide me on how to get started with it?Thanks a lot.
(Reporter)

Comment 6

5 years ago
(In reply to MikeLing from comment #5)
> Hi I am interested in working on this bug,but it's my first time to work on
> with debug,can anybody guide me on how to get started with it?Thanks a lot.

Continuing and replying to what you were asking on IRC:

You cannot use Linux/Ubuntu to fix this bug as the issue is seen only on Windows 7 (Vista may be too). So I guess you will have to use Visual Studio and all those stuff instead of your VM box :).

And thus , I think you already are aware of how to build a basic Firefox build. 

On how to solve the issue :

This will need mostly CSS changes in browser/themes/windows/devtools/debugger.css file.

See http://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/devtools/debugger.css#45

That is the point where the menu item CSS starts.

Please ping me on IRC for further help. My nick is Optimizer.

Comment 7

5 years ago
(In reply to Girish Sharma [:Optimizer] from comment #6)
> (In reply to MikeLing from comment #5)
> > Hi I am interested in working on this bug,but it's my first time to work on
> > with debug,can anybody guide me on how to get started with it?Thanks a lot.
> 
> Continuing and replying to what you were asking on IRC:
> 
> You cannot use Linux/Ubuntu to fix this bug as the issue is seen only on
> Windows 7 (Vista may be too). So I guess you will have to use Visual Studio
> and all those stuff instead of your VM box :).
> 
> And thus , I think you already are aware of how to build a basic Firefox
> build. 
> 
> On how to solve the issue :
> 
> This will need mostly CSS changes in
> browser/themes/windows/devtools/debugger.css file.
> 
> See
> http://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/
> devtools/debugger.css#45
> 
> That is the point where the menu item CSS starts.
> 
> Please ping me on IRC for further help. My nick is Optimizer.

I am so appreciate about you can help and my system is window 7 actually :) .I promise I will fix the issue as soon as possible.Thanks again
(Reporter)

Comment 8

5 years ago
Cool, assigned to you. Thank you for taking it.
Assignee: nobody → sabergeass

Comment 9

5 years ago
(In reply to Girish Sharma [:Optimizer] from comment #8)
> Cool, assigned to you. Thank you for taking it.
Sorry to distrub you,but I find a problem when a build source code
--------------------------------------------------------------------------------------
$ python make.py
Traceback (most recent call last):
  File "make.py", line 10, in <module>
    import pymake.command, pymake.process
  File "d:\mozilla-source\mozilla-central\build\pymake\pymake\command.py", line
14, in <module>
    import data, parserdata, process, util
  File "d:\mozilla-source\mozilla-central\build\pymake\pymake\data.py", line 6,
in <module>
    import parserdata, parser, functions, process, util, implicit
  File "d:\mozilla-source\mozilla-central\build\pymake\pymake\process.py", line
7, in <module>
    import multiprocessing
  File "D:\Python27\Lib\multiprocessing\__init__.py", line 84, in <module>
    import _multiprocessing
ImportError: DLL load failed:%1 is not a valid Win32 application
--------------------------------------------------------------------------------------
but I'm sure I put the python to my PATH(my PATH was blow) what should I do?
--------------------------------------------------------------------------------------
C:\mozilla-build\python;D:\Python32\python;D:\Python27;C:\mozilla-build\svn-win32-1.6.3\bin;C:\mozilla-build\wget;C:\mozilla-build\7zip\Codecs
(Reporter)

Comment 10

5 years ago
On windows, you do not use the make.py directly. Please see the steps here :https://developer.mozilla.org/en-US/docs/Simple_Firefox_build

make sure you have all the prerequisites : https://developer.mozilla.org/en-US/docs/Developer_Guide/Build_Instructions/Windows_Prerequisites
(Reporter)

Comment 11

5 years ago
Hi MikeLing, were you able to make any progress on this bug ? Please let me know how I can help you. If you are not working on this bug, then we can free up this bug for other contributors :)

Comment 12

5 years ago
(In reply to Girish Sharma [:Optimizer] from comment #11)

 Please free up this bug for other contributors,Thanks a lot :)
Assignee: sabergeass → nobody
Status: ASSIGNED → NEW
I'm removing the context menu in bug 905981.
Depends on: 905981
Whiteboard: [good-first-bugs][lang=css][mentor=Optimizer]
Is this still true after the recent theming work? Can we close this bug?
Flags: needinfo?(scrapmachines)
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(scrapmachines)
Resolution: --- → WORKSFORME

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.