Regression in smooth scrolling between Firefox 19 and 20

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: mjh563, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

20 Branch
x86
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Since upgrading to Firefox 20 I've noticed a regression in smooth scrolling performance. 

Steps to reproduce:

1. Load any web page that's longer than the viewport height
2. Scroll up and down using the mouse wheel

Expected results:

The page scrolls smoothly, like it did in Firefox 19.

Actual results:

The scrolling seems less responsive than in Firefox 19, and exhibits a noticeable 'tearing' effect where the top and bottom parts of the page seem to be out of sync when they're displayed. This results in a horizontal line flashing across the page as I scroll up and down, at the point where the two parts of the page meet (the vertical position of this line constantly changes). It's quite noticeable and distracting.
(Reporter)

Comment 1

5 years ago
Regression range is

Last good nightly: 2012-12-11
First bad nightly: 2012-12-12

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4dfe323a663d&tochange=634180132e68

Comment 2

5 years ago
Do you have an example of simple webpage to test scrolling smoothness?
Blocks: 710372
Component: Untriaged → Layout: View Rendering
Flags: needinfo?(mjh563)
Keywords: regression
Product: Firefox → Core
(Reporter)

Comment 3

5 years ago
It happens on all pages, but it's probably more noticeable where there's a greater density of content, such as a block of text. It's also easier to see when you scroll slowly.

As a specific example, go to bug 844406 comment 16, which is quite a long comment. Now scroll that comment up and down using the mouse wheel, as slowly as possible. 

The problem is quite obvious to me when doing that because it gives a kind of 'rippling' effect to the text, as the vertical spacing between various lines momentarily changes during the scroll.
Flags: needinfo?(mjh563)

Comment 4

5 years ago
Is it possible to take a screenshot of this rippling effect or take a screencast (use http://www.screenr.com/ e.g.) please?
(Reporter)

Comment 5

5 years ago
I've tried doing a screencast, but it didn't really show it.
(Reporter)

Comment 7

5 years ago
I can regression-test this issue further, but I don't know how to get a build of a specific commit. Are they downloadable from somewhere, or do I have to build them myself?
I don't think we have any finer grained builds available from back to December. To bisect further you'd either need someone to make you try builds or you could build yourself if you are comfortable doing that. Or I can make try builds in the morning.
(Reporter)

Comment 10

5 years ago
(In reply to Timothy Nikkel (:tn) from comment #9)
> Here are some try builds to try.

Thanks. Only the first one was bad, the others were okay.

Bad:

> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/tnikkel@gmail.com-
> 3a81e8cebc57/

Good:

> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/tnikkel@gmail.com-
> 6bc3b36914dd/
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/tnikkel@gmail.com-
> cf9051a74eae/
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/tnikkel@gmail.com-
> ef0b3b7449f9/
That means that it was bug 731974 that caused it.
Blocks: 731974
If you try the latest nightly do you still see the same problem? Perhaps something has fixed it in the meantime.
(Reporter)

Comment 13

5 years ago
Yes, it still happens in the latest nightly.

Comment 14

5 years ago
Created attachment 732504 [details]
Scrolling artifacts

I am not sure it is helpful, but I got a screenshot of the bug by running Gnome snapshot tool while scrolling the bug report page. Quite a few artifacts are visible in the image; I pointed out some of them.

Comment 15

5 years ago
I realized I forgot to specify version/OS/machine: the attached screen capture refers to Firefox 20.0 64-bit running on RHEL 6 Linux w/ Gnome 2.28; desktop effects (aka Compiz) are not enabled but hardware acceleration is enabled in Firefox. The video card is a Nvidia GT 330.

I also run Firefox under OS X on a MacBook Pro Retina. On that machine/OS the artifacts do not appear to be present.
(Reporter)

Comment 16

5 years ago
(In reply to deodato_art from comment #14)
> I am not sure it is helpful, but I got a screenshot of the bug by running
> Gnome snapshot tool while scrolling the bug report page. Quite a few
> artifacts are visible in the image; I pointed out some of them.

Thanks. I see similar artifacts when I take a screenshot using the Gnome screenshot tool, but I get them with Firefox 19 as well, which was before the scrolling got bad.

Comment 17

5 years ago
Hm. This what I was afraid of... well, then the screenshot is likely not significant. Anyway, I can still confirm that scrolling artifacts appear on Firefox 20 + RHEL6 + NVidia GT 330 :-)
Version 48.0a1 20160323030400 User Agent Mozilla/5.0 (X11; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0
I don't see this issue anymore in the above version.

Since the current issues that involve smooth scrolling and page tearing are related to specific instances: E10s, heavy page load, video streaming and since they are tracked by their own bugs, I'll close this issue as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.