Google Maps mobile site uses -webkit-box-sizing (although it causes no real problems at the moment)

RESOLVED FIXED

Status

Tech Evangelism
Mobile
P5
trivial
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: karlcow)

Tracking

(Blocks: 1 bug, {regression, reproducible})

Trunk
ARM
Android
regression, reproducible
Dependency tree / graph

Firefox Tracking Flags

(firefox22 affected, fennec-)

Details

(Whiteboard: [webkitcss][contactready] [country-all], URL)

(Reporter)

Description

4 years ago
Currently on Google Maps in landscape orientation when the page is done loading, the toolbar is hidden off screen and the Maps toolbar rests at the top of the window. Attempts at manipulating Google Maps reveals the toolbar but overlaps their toolbar making it impossible to interact with.

Can we be smarter here in the toolbar dismissal with this type of content?

See video: http://www.youtube.com/watch?v=c-b7dP4WvWg&list=UUFYtiiCq7UmewNy-pzQTZNg&index=1

--
Nightly (03/13)
Galaxy Note II (Android 4.2)
(Reporter)

Comment 1

4 years ago
Portrait too my mistake.
Keywords: regression, reproducible
Summary: Landscape orientation on Google Maps, toolbar wont hide and blocks content-toolbar → Regression: Google Maps, toolbar wont hide and blocks content-toolbar
Assignee: nobody → chrislord.net
tracking-fennec: ? → 22+

Comment 2

4 years ago
Small note, this is a regression vs. an earlier version of my queue where this used to work perfectly... I suspect a rounding error or a bad rebase, looking at it now.
Status: NEW → ASSIGNED

Comment 3

4 years ago
Ok, so either their site has changed or something has changed in layout since I wrote these patches, as the page is just a few pixels over the viewport - you can actually scroll it if you initiate the scroll from near the search box...

I guess I need to look at the page source and see what it's doing, this could still be our error (but I kinda doubt it).

Comment 4

4 years ago
Looking at the source, I think layout may be doing something wrong here... The map is the correct size, and all of its sibling divs have zero height, yet its parent accumulates 2 pixels from somewhere.

In short, the dynamic toolbar is doing the right thing... I'll drill further to see if this is a problem in layout. Given that this used to work, this may well be a regression.
Component: General → Layout
Product: Firefox for Android → Core

Comment 5

4 years ago
(In reply to Chris Lord [:cwiiis] from comment #4)
> Looking at the source, I think layout may be doing something wrong here...
> The map is the correct size, and all of its sibling divs have zero height,
> yet its parent accumulates 2 pixels from somewhere.
> 
> In short, the dynamic toolbar is doing the right thing... I'll drill further
> to see if this is a problem in layout. Given that this used to work, this
> may well be a regression.

Ignore this - I missed the border on the map element. So it seems that perhaps it's expecting box-sizing:border-box? I'll grep the source now.

Comment 6

4 years ago
Yup, it has an unprefixed box-sizing on the map. This is blocked by bug 243412 - alternatively, maybe evangelism could get them to specify -moz-box-sizing too?
Component: Layout → Mobile
Depends on: 243412
Product: Core → Tech Evangelism
Joanne - This issue impacts mobile and tablet. However, at least on mobile, I can scroll up to cause the awesomebar to move off screen where I can interact with the Google maps toolbar. Can you speak with Google about the issue that Chris identified in comment 6?

Comment 8

4 years ago
Just to add, I got this slightly wrong - they use -webkit-box-sizing only, not an unprefixed box-sizing - a line-break made me miss the prefix. So this is worse, assuming they deliver this page to other non-WebKit engines...

Comment 9

4 years ago
As this is now an evangelism issue, unassigning.
Assignee: chrislord.net → nobody
Status: ASSIGNED → NEW
(Reporter)

Comment 10

4 years ago
Wait a second here ...

I filed this as a functional regression blocking Bug 716403 as the issue here essentially regressed the ability to effectively use the Google Maps map-related toolbar *in-conjunction* with how our dynamic toolbar works (on this page in particular). If you disable (browser.chrome.dynamictoolbar; false), one can use the Google Maps toolbar as normal. That is what this bug is about is it not?
(Reporter)

Comment 11

4 years ago
Ok scratch that I misread, sorry for the noise
So Brad suggested a nice solution for this issue that I'm going to code that means we won't have to rely on evangelism (but we still should, Google seem to be using -webkit-box-sizing quite a lot :/).

I'll open a new bug for said feature and block this with it.

Updated

4 years ago
Depends on: 852565
Blocks: 759981
As the site is now restored to its prior behaviour with bug 852565, retitling to reflect the evangelism issue.
Summary: Regression: Google Maps, toolbar wont hide and blocks content-toolbar → Google Maps mobile site uses -webkit-box-sizing
Removing blocker on dynamic-toolbar since bug #852565 fixes the main issue we had with this.
No longer blocks: 716403
tracking-fennec: 22+ → -
I can no longer reproduce this issue in Firefox 22. I take it that this is a result of the fix in bug 852565 but as there is no issue there is nothing to evangelize in this case. I'm resolving as fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(In reply to Lawrence Mandel [:lmandel] from comment #15)
> I can no longer reproduce this issue in Firefox 22. I take it that this is a
> result of the fix in bug 852565 but as there is no issue there is nothing to
> evangelize in this case. I'm resolving as fixed.

I wouldn't say there's nothing left to evangelise - because of this, this site has an unnecessary 2 pixels that you can scroll the page by (which feels broken if you manage to do it).

It's not much, so at your discretion, but they really shouldn't be using -webkit-box-sizing and no other prefixed or unprefixed versions of this property...
reopening per comment 16
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Thanks for the clarification Chris. We'll include this in our Google Maps request.
In all the code G Maps sends, I find this single instance of -webkit-box-sizing, in an inline style sheet:

gbsb{-webkit-box-sizing:border-box;display:block;position:relative;*zoom:1}
Severity: normal → trivial
Status: REOPENED → NEW
Priority: -- → P5
Summary: Google Maps mobile site uses -webkit-box-sizing → Google Maps mobile site uses -webkit-box-sizing (although it causes no real problems at the moment)
Whiteboard: [webkitcss][contactready]
(Assignee)

Updated

3 years ago
(Assignee)

Updated

3 years ago
Assignee: nobody → kdubost
Whiteboard: [webkitcss][contactready] → [webkitcss][contactready] [country-all]
(Assignee)

Comment 20

3 years ago
After checking the CSS, most of the -webkit- which matters seem to have their counterpart for other browsers. Closing as FIXED.

.gb_s{display:inline-block;
    outline:none;
    vertical-align:middle;
    -moz-border-radius:2px;
    border-radius:2px;
    -moz-box-sizing:border-box;
    box-sizing:border-box;
    height:30px;
    width:30px}
Status: NEW → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.