DoorHanger layout files are redundant

RESOLVED FIXED in Firefox 23

Status

()

Firefox for Android
Theme and Visual Design
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 23
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
There are 2 layout files for doorhangerpopup (and site_identity_popup) differing only my the width attribute. A good approach would be specify it as a theme level attribute, and use it here.
(Assignee)

Updated

5 years ago
Blocks: 823644
(Assignee)

Comment 1

5 years ago
Created attachment 724778 [details] [diff] [review]
Patch

Finally, just one layout file.
Attachment #724778 - Flags: review?(mark.finkle)
(Assignee)

Comment 2

5 years ago
Created attachment 724787 [details] [diff] [review]
Patch

This is a better patch.
Attachment #724787 - Flags: review?(mark.finkle)
(Assignee)

Updated

5 years ago
Attachment #724778 - Attachment is obsolete: true
Attachment #724778 - Flags: review?(mark.finkle)

Updated

5 years ago
Duplicate of this bug: 751205
Attachment #724787 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/505fbab9b980
Backed out the whole push in https://hg.mozilla.org/integration/mozilla-inbound/rev/5eb7efc431c8 for mochitest-1 and robocop-2 errors about "Error inflating class android.widget.Button" like https://tbpl.mozilla.org/php/getParsedLog.php?id=20799813&tree=Mozilla-Inbound and https://tbpl.mozilla.org/php/getParsedLog.php?id=20798777&tree=Mozilla-Inbound
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c6e7a7888876
https://hg.mozilla.org/mozilla-central/rev/c6e7a7888876
Assignee: nobody → sriram
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
You need to log in before you can comment on or make changes to this bug.