URL does not load when opening private browsing window

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: daniela.p98911, Assigned: daniela.p98911)

Tracking

(Depends on: 1 bug)

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox21 fixed, firefox22 fixed, firefox23 fixed, firefox24 fixed)

Details

(Whiteboard: [blocked by bug 847991])

Attachments

(3 attachments, 3 obsolete attachments)

(Assignee)

Description

6 years ago
Created attachment 724818 [details]
Screenshot with how it looks like when the error reprodces

This is a follow up on bug 827752. The issue is that the URL does not load after opening the PB window. It happens in testFlashCookie.js and testAboutCache.js . The issue is intermittent. 

testAboutCache.js does not fail because we are just waiting for the pages to load, but do not check which were loaded. 

testFlashCookie.js fails because it cannot find an element on the page it did not load. Test results are (with --show-errors):
TEST-START | /home/danielapetrovici/Documents/827752/03_05_2013/mozmill-tests/tests/functional/testPrivateBrowsing/testFlashCookie.js | setupModule
TEST-PASS | /home/danielapetrovici/Documents/827752/03_05_2013/mozmill-tests/tests/functional/testPrivateBrowsing/testFlashCookie.js | testFlashCookie.js::setupModule
TEST-START | /home/danielapetrovici/Documents/827752/03_05_2013/mozmill-tests/tests/functional/testPrivateBrowsing/testFlashCookie.js | testCheckFlashCookie
ERROR | Test Failure: {"exception": {"stack": "MozMillController.prototype.type@resource://mozmill/modules/controller.js:418\ntestCheckFlashCookie@resource://mozmill/modules/frame.js -> file:///home/danielapetrovici/Documents/827752/03_05_2013/mozmill-tests/tests/functional/testPrivateBrowsing/testFlashCookie.js:39\nRunner.prototype.wrapper@resource://mozmill/modules/frame.js:595\nRunner.prototype._runTestModule@resource://mozmill/modules/frame.js:665\nRunner.prototype.runTestModule@resource://mozmill/modules/frame.js:711\nRunner.prototype.runTestFile@resource://mozmill/modules/frame.js:544\nrunTestFile@resource://mozmill/modules/frame.js:723\nBridge.prototype._execFunction@resource://jsbridge/modules/server.js:179\nBridge.prototype.execFunction@resource://jsbridge/modules/server.js:183\n@resource://jsbridge/modules/server.js:283\n", "message": "could not find element ID: cookieValue", "fileName": "resource://mozmill/modules/controller.js", "name": "Error", "lineNumber": 418}}
TEST-UNEXPECTED-FAIL | /home/danielapetrovici/Documents/827752/03_05_2013/mozmill-tests/tests/functional/testPrivateBrowsing/testFlashCookie.js | testFlashCookie.js::testCheckFlashCookie
TEST-START | /home/danielapetrovici/Documents/827752/03_05_2013/mozmill-tests/tests/functional/testPrivateBrowsing/testFlashCookie.js | teardownModule
TEST-PASS | /home/danielapetrovici/Documents/827752/03_05_2013/mozmill-tests/tests/functional/testPrivateBrowsing/testFlashCookie.js | testFlashCookie.js::teardownModule
NOTE: child process received `Goodbye', closing down
INFO Passed: 2
INFO Failed: 1
INFO Skipped: 0

The error for this test is: "could not find element ID: cookieValue"

NOTE: I have also added a screenshot with how it looks when the error appears
(Assignee)

Updated

6 years ago
Blocks: 827752
Even we can't see this problem in the aboutCache test we might end-up in not handling this test correctly given that the page is not cached at all. I consider this important so lets get to it by next week.
Blocks: 789987
OS: Linux → All
Priority: -- → P2
Hardware: x86 → All
Whiteboard: s=130318 u=failure c=private_browsing p=1
You may be seeing bug 847991, depending on how you trigger the loads.
Thanks Josh. Sounds like we hit this. We usually trigger the pb window via a keyboard shortcut or the main menu. Once the window is open and is loaded, we directly fire the request to load another page. And that doesn't seem to work. Daniela, can you please confirm that in such a case e.g. the flash test, you do not see the flash page but about:privatebrowsing?
(Assignee)

Comment 4

6 years ago
Yes, this is the case in both testFlashCookie.js and testAboutCache.js
(Assignee)

Comment 5

6 years ago
Created attachment 724941 [details] [diff] [review]
patch v1.0 to fix testAboutCache.js

This is the patch to fix the testAboutCache.js test before bug 847991 is fixed.
Attachment #724818 - Attachment is obsolete: true
Attachment #724941 - Flags: review?(andreea.matei)
Depends on: 847991
Simple patch to fix this bug for now. I don't see a need to account a sprint entry for.
Assignee: nobody → dpetrovici
Status: NEW → ASSIGNED
Whiteboard: s=130318 u=failure c=private_browsing p=1
Comment on attachment 724941 [details] [diff] [review]
patch v1.0 to fix testAboutCache.js

Review of attachment 724941 [details] [diff] [review]:
-----------------------------------------------------------------

Instead of modifying each of those test files, why can't we add this to the private browsing ui module?
Attachment #724941 - Flags: review?(andreea.matei) → review-
(Assignee)

Comment 8

6 years ago
Created attachment 725304 [details] [diff] [review]
patch v1.1

Modified the private-browsing library per review
Attachment #724941 - Attachment is obsolete: true
Attachment #725304 - Flags: review?(andreea.matei)
(Assignee)

Updated

6 years ago
Attachment #725304 - Attachment description: patch v1.8 → patch v1.1
Comment on attachment 725304 [details] [diff] [review]
patch v1.1

Review of attachment 725304 [details] [diff] [review]:
-----------------------------------------------------------------

Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/78dcfe10921a (default)

Please check for Aurora as well.
Attachment #725304 - Flags: review?(andreea.matei) → review+
status-firefox22: --- → fixed
(Assignee)

Comment 10

6 years ago
The issue with testAboutCache.js reproduces on Aurora, too. The patch applies cleanly on this branch also
Transplanted:
http://hg.mozilla.org/qa/mozmill-tests/rev/00006aaabfc4 (aurora)

Leaving bug open giving that this is just a workaround.
status-firefox21: --- → fixed
So, what's left on this bug? Can it be closed?
(Assignee)

Comment 13

6 years ago
(In reply to Henrik Skupin (:whimboo) from comment #12)
> So, what's left on this bug? Can it be closed?
I don't think it should be closed since the dependent bug is still not fixed. We would need to remove the workaround when bug 847991 is fixed.
Whiteboard: [blocked by bug 847991]
Duplicate of this bug: 860665
The landed patch will break the upcoming Mozmill 2.0 testrun given that waitForPageLoad() is called twice. Daniela, please update the manifest to account that.
(Assignee)

Comment 16

6 years ago
Created attachment 749264 [details] [diff] [review]
follow-up patch v1.0

(In reply to Henrik Skupin (:whimboo) from comment #15)
> The landed patch will break the upcoming Mozmill 2.0 testrun given that
> waitForPageLoad() is called twice. Daniela, please update the manifest to
> account that.

Actually this is a thing I have forgotten when implementing the change in the open method in pbWindow. 

The open method had been changed so that it will wait for the page to load so that we do not have it added in the tests. But I forgot to check the existing tests where this method was already added. 

I have removed it now from the remaining test. Reports are below:
MAC: mozmill-crowd.blargon7.com/#/functional/report/14f8bc4e22e61353662cded4c21cc7f4
Linux: http://mozmill-crowd.blargon7.com/#/functional/report/14f8bc4e22e61353662cded4c21b7654
Windows: http://mozmill-crowd.blargon7.com/#/functional/report/14f8bc4e22e61353662cded4c21d078c
Attachment #749264 - Flags: review?(andreea.matei)
Comment on attachment 749264 [details] [diff] [review]
follow-up patch v1.0

Review of attachment 749264 [details] [diff] [review]:
-----------------------------------------------------------------

So the second waitForPageLoad() call in the test itself is not necessary? Means it will still work with Mozmill 1.5? Why do you comment it out instead of removing it?
Attachment #749264 - Flags: review?(andreea.matei) → review-
(Assignee)

Comment 18

6 years ago
Created attachment 749277 [details] [diff] [review]
follow-up patch v1.1

> So the second waitForPageLoad() call in the test itself is not necessary?
> Means it will still work with Mozmill 1.5?
Yes, it will still work in Mozmill 1.5 without it. It was not necessary.

> Why do you comment it out instead of removing it?
Sorry about that. I have attached the correct patch now.
Attachment #749264 - Attachment is obsolete: true
(Assignee)

Updated

6 years ago
Attachment #749277 - Flags: review?(andreea.matei)
Comment on attachment 749277 [details] [diff] [review]
follow-up patch v1.1

Review of attachment 749277 [details] [diff] [review]:
-----------------------------------------------------------------

http://hg.mozilla.org/qa/mozmill-tests/rev/235e25d5118d (default)

It will need backport for all except esr17.
Attachment #749277 - Flags: review?(andreea.matei) → review+
status-firefox21: fixed → affected
status-firefox22: fixed → affected
status-firefox23: --- → affected
status-firefox24: --- → fixed
Comment on attachment 749841 [details] [diff] [review]
follow up patch v1.0 for Beta and Release

Review of attachment 749841 [details] [diff] [review]:
-----------------------------------------------------------------

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/f0f82ed507d6 (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/08b5794a2bff (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/590db92913fd (release)

Now we should fix bug 872484 for 2.0.
Attachment #749841 - Flags: review?(andreea.matei) → review+
status-firefox21: affected → fixed
status-firefox22: affected → fixed
status-firefox23: affected → fixed
Andreea, can we close this bug as resolved fixed now?
We could close it for now as we will receive a notification email when the dependency is solved (bug 847991).
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.