cookieService getCookieString method fails when user has "never remember history" privacy setting checked

RESOLVED DUPLICATE of bug 763904

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 763904
5 years ago
4 years ago

People

(Reporter: wtravishardman, Unassigned)

Tracking

19 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.172 Safari/537.22

Steps to reproduce:

I am using the add-on SDK to develop an add-on that uses http to communicate with a server, and uses the browser cookies to maintain a session. In the extension, I call getCookieStringFromHttp (although getCookieString seems to have the same problem) in order to find out if the session cookie exists and whether to bother making a request that requires authentication.

If I have Firefox set to remember history, everything works as expected and the getCookieStringFromHttp method returns a string of the cookies that would be passed with my provided url. The problem occurs when the user has set "never remember history".


Actual results:

When the user sets "never remember history" in the privacy settings then logs into the site in question, Firebug reports that the sessionid cookie (and all other cookies, are set correctly). However, the getCookieStringFromHttp and getCookieString methods return only the string "sessionid=" rather than the full cookie string from the domain.


Expected results:

The getCookieStringFromHttp and getCookieString methods should have returned all of the cookies associated with the provided URL.

Updated

5 years ago
Depends on: 823941

Comment 1

5 years ago
Is this just an SDK issue?  The nsiCookieService methods have been modified to work with private browsing.

Comment 2

5 years ago
I think this is a dupe of bug 823941.  GetCookieString and GetCookieStringFromHttp are now unaware of private cookies, even in permanent PB mode.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 823941
Resolution: --- → DUPLICATE
Duplicate of bug: 763904
You need to log in before you can comment on or make changes to this bug.