[GAIA System] GAIA System have to send Radio Power Off when power off.

RESOLVED DUPLICATE of bug 1129272

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1129272
5 years ago
3 years ago

People

(Reporter: leo.bugzilla.gecko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Mobile phone has to notify to network when powering off.
The network has to inform to user the phone is power-off or not when user called.

But, GAIA system didn't send RADIO_POWER off to modem.
it is only send when airplane mode on. ( sleep_menu.js ) 

      case 'airplane':
 
        if (!window.navigator.mozSettings)
          return;

        SettingsListener.getSettingsLock().set({
          'ril.radio.disabled': !this.isFlightModeEnabled
        });

        break;


The method sending RADIO_POWER off message to modem side has to be implemented.
Maybe it has to be implementd with RIL layer together .

If it is not implementd, many radio related test case fail. 

Thanks
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?

Comment 1

5 years ago
Kevin - can you help find an assignee in Taipei? Should be a minor change here.
blocking-b2g: leo? → leo+
Flags: needinfo?(khu)

Comment 2

5 years ago
Tim and Alive are in PTO. 
Evelyn, could you help this case? Thank you!
Flags: needinfo?(khu) → needinfo?(ehung)

Comment 3

5 years ago
ok, seems an issue I can help.
Assignee: nobody → ehung
Flags: needinfo?(ehung)

Comment 4

5 years ago
we can't use ril.radio.disabled setting in this case because it indicates "airplane mode" state. If we set it when powering off, we will be in airplane mode next time.
File bug 856553 for Gecko API support.

Updated

5 years ago
Depends on: 856553

Comment 5

5 years ago
Commercial RIL supports this feature, so this should not be a leo+.
blocking-b2g: leo+ → ---

Comment 6

5 years ago
de-assign myself from this issue.
Assignee: ehung → nobody

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1129272
You need to log in before you can comment on or make changes to this bug.