Closed Bug 851555 Opened 8 years ago Closed 8 years ago

iceweasel: Debian-Wheezy beta diverts firefox -> iceweasel, mozilla-firefox is not workable anyway

Categories

(Firefox :: Installer, defect)

17 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 723487

People

(Reporter: aglaeser1, Unassigned)

Details

(Keywords: 64bit, arch)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.12) Gecko/20100101 Firefox/10.0.12 Iceweasel/10.0.12
Build ID: 20130108202048

Steps to reproduce:

andreas@s-450:~$ sudo apt-get remove iceweasel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  iceweasel
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
After this operation, 6,570 kB disk space will be freed.
Do you want to continue [Y/n]? 
(Reading database ... 172624 files and directories currently installed.)
Removing iceweasel ...
Removing 'diversion of /usr/bin/firefox to /usr/bin/firefox.real by iceweasel'
Processing triggers for menu ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for mime-support ...
andreas@s-450:~$ tar -xjvf firefox-17.0.4esr.tar.bz2 
firefox/
firefox/mozilla-xremote-client
firefox/platform.ini
firefox/libsoftokn3.chk
firefox/libnssckbi.so
firefox/libxul.so
firefox/crashreporter-override.ini
firefox/libxpcom.so
firefox/libmozsqlite3.so
firefox/crashreporter.ini
firefox/update-settings.ini
firefox/webapprt-stub
firefox/icons/
firefox/icons/updater.png
firefox/icons/mozicon128.png
firefox/libplds4.so
firefox/extensions/
firefox/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/
firefox/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/icon.png
firefox/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/install.rdf
firefox/application.ini
firefox/Throbber-small.gif
firefox/chrome/
firefox/chrome/icons/
firefox/chrome/icons/default/
firefox/chrome/icons/default/default16.png
firefox/chrome/icons/default/default32.png
firefox/chrome/icons/default/default48.png
firefox/libsmime3.so
firefox/firefox-bin
firefox/omni.ja
firefox/dependentlibs.list
firefox/defaults/
firefox/defaults/pref/
firefox/defaults/pref/channel-prefs.js
firefox/defaults/preferences/
firefox/libnssdbm3.chk
firefox/blocklist.xml
firefox/libnssutil3.so
firefox/libnssdbm3.so
firefox/precomplete
firefox/updater
firefox/run-mozilla.sh
firefox/components/
firefox/components/binary.manifest
firefox/components/libdbusservice.so
firefox/components/libmozgnome.so
firefox/components/libbrowsercomps.so
firefox/components/libnkgnomevfs.so
firefox/libplc4.so
firefox/plugin-container
firefox/updater.ini
firefox/libnspr4.so
firefox/chrome.manifest
firefox/webapprt/
firefox/webapprt/webapprt.ini
firefox/webapprt/omni.ja
firefox/webapprt/components/
firefox/removed-files
firefox/searchplugins/
firefox/searchplugins/eBay-en-GB.xml
firefox/searchplugins/wikipedia.xml
firefox/searchplugins/yahoo-en-GB.xml
firefox/searchplugins/twitter.xml
firefox/searchplugins/google.xml
firefox/searchplugins/bing.xml
firefox/searchplugins/amazon-en-GB.xml
firefox/searchplugins/chambers-en-GB.xml
firefox/libsoftokn3.so
firefox/libmozalloc.so
firefox/firefox
firefox/libfreebl3.chk
firefox/libfreebl3.so
firefox/libssl3.so
firefox/libnss3.so
firefox/crashreporter
IE8-WindowsXP-x86-DEU.exe
andreas@s-450:~$ cd firefox
andreas@s-450:~/firefox$ ./firefox
XPCOMGlueLoad error for file /home/andreas/firefox/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
andreas@s-450:~/firefox$ cd ..
andreas@s-450:~$ sudo apt-get install iceweasel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  mozplugger libgssapi-krb5-2 libkrb53
The following NEW packages will be installed:
  iceweasel
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/1,455 kB of archives.
After this operation, 6,570 kB of additional disk space will be used.
Selecting previously unselected package iceweasel.
(Reading database ... 172478 files and directories currently installed.)
Unpacking iceweasel (from .../iceweasel_10.0.12esr-1_amd64.deb) ...
Adding 'diversion of /usr/bin/firefox to /usr/bin/firefox.real by iceweasel'
Processing triggers for mime-support ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for menu ...
Setting up iceweasel (10.0.12esr-1) ...
update-alternatives: using /usr/bin/iceweasel to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
update-alternatives: using /usr/bin/iceweasel to provide /usr/bin/gnome-www-browser (gnome-www-browser) in auto mode
Processing triggers for menu ...
andreas@s-450:~$ aptitude show mozplugger
No current or candidate version found for mozplugger
Package: mozplugger
State: not a real package

andreas@s-450:~$ aptitude show libgssapi-krb5-2
Package: libgssapi-krb5-2                
State: installed
Automatically installed: no
Multi-Arch: same
Version: 1.10.1+dfsg-4
Priority: standard
Section: libs
Maintainer: Sam Hartman <hartmans@debian.org>
Architecture: amd64
Uncompressed Size: 344 k
Depends: libc6 (>= 2.7), libcomerr2 (>= 1.34), libk5crypto3 (>= 1.8+dfsg), libkeyutils1, libkrb5-3 (= 1.10.1+dfsg-4), libkrb5support0 (>=
         1.7dfsg~beta2)
PreDepends: multiarch-support
Suggests: krb5-doc, krb5-user
Breaks: libgssglue1 (< 0.2-2), libgssglue1 (< 0.2-2), libgssapi-krb5-2 (!= 1.10.1+dfsg-4)
Replaces: libgssapi-krb5-2 (< 1.10.1+dfsg-4)
Description: MIT Kerberos runtime libraries - krb5 GSS-API Mechanism
 Kerberos is a system for authenticating users and services on a network. Kerberos is a trusted third-party service.  That means that there
 is a third party (the Kerberos server) that is trusted by all the entities on the network (users and services, usually called
 "principals"). 
 
 This is the MIT reference implementation of Kerberos V5. 
 
 This package contains the runtime library for the MIT Kerberos implementation of GSS-API used by applications and Kerberos clients.
Homepage: http://web.mit.edu/kerberos/

andreas@s-450:~$ aptitude show libkrb53
No current or candidate version found for libkrb53
Package: libkrb53
State: not a real package




Actual results:

Firefox is not workable on Debian Wheezy beta. I chose to show this with the ESR 17 - version, because this probably matches dabian better than the current 'stable' version 19.
If I wanted to report this as an iceweasel-issue in Debian it would look like this:
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: andreas glaeser <andreas@s-450.lokal>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: iceweasel: Debian-Wheezy beta diverts firefox -> iceweasel,
 mozilla-firefox not workable anyway
Bcc: andreas glaeser <andreas@s-450.lokal>

Package: iceweasel
Version: 10.0.12esr-1
Severity: normal

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these lines ***


-- Package-specific info:

-- Extensions information
Name: Adblock Plus
Location: /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Package: xul-ext-adblock-plus
Status: enabled

Name: Default theme
Location: /usr/lib/iceweasel/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
Package: iceweasel
Status: enabled

Name: Ghostery
Location: ${PROFILE_EXTENSIONS}/firefox@ghostery.com
Status: enabled

Name: HTTPS-Everywhere
Location: ${PROFILE_EXTENSIONS}/https-everywhere@eff.org
Status: enabled

-- Plugins information
Name: Gnome Shell Integration
Location: /usr/lib/mozilla/plugins/libgnome-shell-browser-plugin.so
Package: gnome-shell
Status: enabled

Name: iTunes Application Detector
Location: /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so
Package: rhythmbox-plugins
Status: enabled

Name: Shockwave Flash
Location: /usr/lib/gnash/libgnashplugin.so
Package: browser-plugin-gnash
Status: enabled


-- Addons package information
ii  browser-plugin 0.8.11~git20 amd64        GNU Shockwave Flash (SWF) player 
ii  gnome-shell    3.4.2-7      amd64        graphical shell for the GNOME des
ii  iceweasel      10.0.12esr-1 amd64        Web browser based on Firefox
ii  rhythmbox-plug 2.97-2.1     amd64        plugins for rhythmbox music playe
ii  xul-ext-adbloc 2.1-1        all          Advertisement blocking extension 

-- System Information:
Debian Release: 7.0
  APT prefers testing-updates
  APT policy: (500, 'testing-updates'), (500, 'testing-proposed-updates'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.8.0adt
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages iceweasel depends on:
ii  debianutils         4.3.2
ii  fontconfig          2.9.0-7.1
ii  libc6               2.13-38
ii  libgdk-pixbuf2.0-0  2.26.1-1
pn  libglib2.0-0        <none>
ii  libgtk2.0-0         2.24.10-2
ii  libnspr4            2:4.9.2-1
ii  libnspr4-0d         2:4.9.2-1
pn  libsqlite3-0        <none>
ii  libstdc++6          4.7.2-5
ii  procps              1:3.3.3-2
ii  xulrunner-10.0      10.0.12esr-1

iceweasel recommends no packages.

Versions of packages iceweasel suggests:
ii  fonts-stix [otf-stix]        1.1.0-1
pn  libgssapi-krb5-2 | libkrb53  <none>
pn  mozplugger                   <none>

Versions of packages xulrunner-10.0 depends on:
ii  libasound2                1.0.25-4
ii  libatk1.0-0               2.4.0-2
pn  libbz2-1.0                <none>
ii  libc6                     2.13-38
pn  libcairo2                 <none>
ii  libdbus-1-3               1.6.8-1
ii  libdbus-glib-1-2          0.100.2-1
pn  libevent-2.0-5            <none>
ii  libfontconfig1            2.9.0-7.1
ii  libfreetype6              2.4.9-1.1
ii  libgcc1                   1:4.7.2-5
ii  libgdk-pixbuf2.0-0        2.26.1-1
pn  libglib2.0-0              <none>
ii  libgtk2.0-0               2.24.10-2
ii  libhunspell-1.3-0         1.3.2-4
ii  libjpeg8                  8d-1
ii  libmozjs10d               10.0.12esr-1
ii  libnotify4                0.7.5-1
ii  libnspr4-0d               2:4.9.2-1
ii  libnss3-1d                2:3.13.6-2
ii  libpango1.0-0             1.30.0-1
pn  libpixman-1-0             <none>
pn  libreadline6              <none>
pn  libsqlite3-0              <none>
ii  libstartup-notification0  0.12-1
ii  libstdc++6                4.7.2-5
ii  libvpx1                   1.1.0-1
ii  libx11-6                  2:1.5.0-1
ii  libxext6                  2:1.3.1-2
ii  libxrender1               1:0.9.7-1
ii  libxt6                    1:1.1.3-1
ii  zlib1g                    1:1.2.7.dfsg-13

Versions of packages xulrunner-10.0 suggests:
ii  libcanberra0  0.28-6
ii  libgnomeui-0  2.24.5-2

-- no debconf information
***
----
Because firefox is not runnable, I set up iceweasel again in order to be able to file this report.


Expected results:

Users should be able to install the Firefox-browser either in the ESR-version or in the current stable version instead of iceweasel. It s currently OK in my opinion as long as Wheezy is still in beta state, but once it is released as stable, version 10 will be quite outdated already considering the fast paced development in internet-technology. 
I imagine that some web-developers will want to have a more recent firefox-version on Debian Wheezy in order to be up to date with current web-technologies and -standards.
So please make this possible again.
This page about Firefox-Linux-install was not helpfull and I told you so before:
https://support.mozilla.org/en-US/kb/install-firefox-linux
When trying to set up the most recent iceweasel-version from Debian experimental, it will not work either, because of unmet dependencies:
andreas@s-450:~$ sudo apt-get install -t experimental iceweasel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 iceweasel : Depends: xulrunner-19.0 (>= 19.0.2-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
----
So overall more recent Firefox/Iceweasel versions are not installable or not usable due to dependency-problems or would require mixing of different distribution-branches and this is asking for trouble, that average users do not want to have, so I do not either.
(In reply to Andreas Glaeser from comment #0)
>libxul.so: cannot open shared object file: No such file or directory

This is bug 723487, which is marked as fixed, but without a patch. Could you try following the guidelines in the last couple 10-15 comments? Those seemed to do the trick for most people.
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit
This was really just an issue of wrong architecture. I fetched the AMD64-Version here:
ftp://ftp.mozilla.org/pub/firefox/releases/17.0.4esr/linux-x86_64/en-GB/
and this is doing fine now.
But still I think that things should work by default and users should not be made run into trouble, so when downloading Firefox here:
https://www.mozilla.org/de/download/?product=firefox-19.0.2&os=linux&lang=de
the correct architecture should be detectable, i.e. wether it is i486-32bit or AMD64-64bit.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Component: Startup and Profile System → Installer
Keywords: 64bit, arch
Product: Toolkit → Firefox
Resolution: --- → DUPLICATE
Duplicate of bug: 723487
You need to log in before you can comment on or make changes to this bug.