Closed Bug 851630 Opened 8 years ago Closed 8 years ago

Can't open popup notifications with the keyboard (focus gets stuck at the identity icon)

Categories

(Firefox :: Address Bar, defect)

defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 23
Tracking Status
firefox19 --- unaffected
firefox20 --- unaffected
firefox21 + verified
firefox22 + verified

People

(Reporter: dao, Assigned: Gavin)

References

Details

(Keywords: access, regression, verifyme)

Attachments

(1 file)

STR:
1. focus the location bar
2. hit Shift+Tab (focuses the identity icon)
3. hit Shift+Tab again

expected result: focus moves on from the identity icon to the previous focusable icon (e.g. a popup notification anchor if present)

actual result: focus gets stuck at the identity icon
In triage, we weren't able to repro on FF20, but 21 appears to be affected.
Keywords: qawanted
Last good nightly: 2013-02-11
First bad nightly: 2013-02-12

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5835bc763be7&tochange=36525224b14e
QA Contact: anthony.s.hughes
Bholley: is this possible fallout from bug 839867?
Assignee: nobody → bobbyholley+bmo
(In reply to lsblakk@mozilla.com from comment #3)
> Bholley: is this possible fallout from bug 839867?

I doubt it, unless frontend code expects to be able to write location.hash cross-origin for some reason (which seems unlikely, because all that stuff should be System Principal).

Either way, I'm not the appropriate assignee for this bug until we're more sure of the nature of the platform regression, if any.
Assignee: bobbyholley+bmo → nobody
Gavin, would you say initial investigation here falls on your team? We don't want to introduce a focus/a11y regression in FF21.
Flags: needinfo?(gavin.sharp)
I bisected, this looks to have been caused by bug 758288, which is somewhat mysterious at first glance.
Blocks: 758288
Flags: needinfo?(gavin.sharp)
OS: Windows 7 → All
Hardware: x86_64 → All
I guess http://hg.mozilla.org/mozilla-central/annotate/2949e808ed33/dom/src/events/nsJSEventListener.cpp#l254 treats undefined differently than "false", so that patch changed behavior.

Should we just switch this to a "return true"?
Gavin can you take this on or re-assign if necessary? We'll need a speculative fix for this landed & verified before next Tuesday when we build 21.0b4.
Assignee: nobody → gavin.sharp
Attached patch patchSplinter Review
Given the comment, I think this was just a mistake.
Attachment #737729 - Flags: review?(dao)
Attachment #737729 - Flags: review?(dao) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/11336b456004
Flags: in-testsuite-
Target Milestone: --- → Firefox 23
Comment on attachment 737729 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 758288
User impact if declined: as summarized
Testing completed (on m-c, etc.): tested manually
Risk to taking this patch (and alternatives if risky): no risk, just reverting an unintentional behavior change
String or IDL/UUID changes made by this patch: none
Attachment #737729 - Flags: approval-mozilla-beta?
Attachment #737729 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/11336b456004
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 737729 [details] [diff] [review]
patch

low risk patch,looks good to uplift. Requesting QA verification once this lands on branches.
Attachment #737729 - Flags: approval-mozilla-beta?
Attachment #737729 - Flags: approval-mozilla-beta+
Attachment #737729 - Flags: approval-mozilla-aurora?
Attachment #737729 - Flags: approval-mozilla-aurora+
Keywords: verifyme
Verified fixed in Firefox Nightly 23.0a1 2013-04-17. Added to queue for Firefox 21b4 sign-off.
Status: RESOLVED → VERIFIED
Status: RESOLVED → VERIFIED
Duplicate of this bug: 862807
Verified as fixed on FF 21 beta 4 (build ID: 20130423212553)

User agents:
Windows XP: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
Windows 7x64: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Ubuntu 12.04: Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0
Mac OSX 10.8: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0
Verified fixed with Firefox 22 beta 1 (build ID: 20130514181517) on Mac OSX 10.7.5 and Ubuntu 12.10 32bit.
You need to log in before you can comment on or make changes to this bug.