Last Comment Bug 851662 - [Australis-tabs-XP] Text color and icons are black with dark custom-theme.
: [Australis-tabs-XP] Text color and icons are black with dark custom-theme.
Status: RESOLVED WONTFIX
[Australis:M-]
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86 Windows XP
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Dão Gottwald [:dao]
Mentors:
Depends on:
Blocks: australis-tabs-win
  Show dependency treegraph
 
Reported: 2013-03-15 14:11 PDT by scheco
Modified: 2016-02-24 09:40 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
issue.png (38.22 KB, image/png)
2013-03-15 14:11 PDT, scheco
no flags Details
Same problem with a different theme (332.66 KB, image/png)
2013-03-16 04:29 PDT, jonrandy
no flags Details
Same theme - different problem (91.73 KB, image/png)
2013-03-16 04:33 PDT, jonrandy
no flags Details
"Maximized window" problem solved. (148.74 KB, image/png)
2013-04-21 17:00 PDT, scheco
no flags Details
"Restored window" problem remains. (229.46 KB, image/png)
2013-04-21 17:03 PDT, scheco
no flags Details
Screenshot with maximized window (203.49 KB, image/png)
2013-05-24 22:26 PDT, scheco
no flags Details
Screenshot with restored window (199.56 KB, image/png)
2013-05-24 22:26 PDT, scheco
no flags Details
Reg Nightly Maximized (214.20 KB, image/png)
2013-05-25 21:27 PDT, scheco
no flags Details
Reg Nightly Restored (271.48 KB, image/png)
2013-05-25 21:28 PDT, scheco
no flags Details

Description User image scheco 2013-03-15 14:11:24 PDT
Created attachment 725591 [details]
issue.png

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20130314 Firefox/22.0
Build ID: 20130314040206
Comment 1 User image jonrandy 2013-03-16 04:29:57 PDT
Created attachment 725749 [details]
Same problem with a different theme
Comment 2 User image jonrandy 2013-03-16 04:33:18 PDT
Created attachment 725750 [details]
Same theme - different problem

When the window is not minimised, the theme appears to be drawn incorrectly
Comment 3 User image Matthew N. [:MattN] (PM if requests are blocking you) 2013-04-18 16:40:40 PDT
Is this still reproducible on UX? I think it was fixed by using the system text color.
Comment 4 User image scheco 2013-04-21 16:56:45 PDT
Yes, the problem when the window is maximized was solved. However, when it is restored there are still conflicts in the text color and window control buttons.
Comment 5 User image scheco 2013-04-21 17:00:39 PDT
Created attachment 740133 [details]
"Maximized window" problem solved.
Comment 6 User image scheco 2013-04-21 17:03:25 PDT
Created attachment 740134 [details]
"Restored window" problem remains.
Comment 7 User image :Gijs 2013-05-21 02:26:59 PDT
I tried to reproduce this at one point but got stuck because on Windows XP 64-bit, theming custom non-MS themes seem to not work at all. Reporter, any chance of more detailed steps to reproduce this? :-)
Comment 8 User image scheco 2013-05-22 20:23:59 PDT
obviously :)
-) Go to this page, download and install this visual style.
-) Open UX, and use it without light-themes.
-) Set the window in "restored mode".


I do not know if it happens in ALL dark custom themes, or only that are not developed by Microsoft.
Comment 9 User image scheco 2013-05-22 20:24:46 PDT
download.tune-up.com/visualstyles/Islander_VS_Aquatic.tvs
Comment 10 User image Matthew N. [:MattN] (PM if requests are blocking you) 2013-05-23 08:07:38 PDT
M- for now unless this can be reproduced without third-party Windows themes.
Comment 11 User image Justin Dolske [:Dolske] 2013-05-24 15:52:40 PDT
Is this a bug with current Nightly/Release as well? Or does Australis make it work? Screenshot of Nightly would be helpful.
Comment 12 User image scheco 2013-05-24 22:26:03 PDT
Created attachment 754066 [details]
Screenshot  with maximized window
Comment 13 User image scheco 2013-05-24 22:26:51 PDT
Created attachment 754067 [details]
Screenshot  with restored window
Comment 14 User image Matthew N. [:MattN] (PM if requests are blocking you) 2013-05-24 23:46:26 PDT
(Quoting Justin Dolske [:Dolske] from comment #11)
> Is this a bug with current Nightly/Release as well? Or does Australis make
> it worse? Screenshot of Nightly would be helpful.

scheco, dolske was asking about the regular mozilla-central Nightlies from http://nightly.mozilla.org/ not UX nightlies. We want to know whether Australis is making this problem worse.
Comment 15 User image scheco 2013-05-25 21:27:21 PDT
Created attachment 754190 [details]
Reg Nightly Maximized

oh so sorry !..
Here are the screenshots with reg Nightly
Comment 16 User image scheco 2013-05-25 21:28:16 PDT
Created attachment 754191 [details]
Reg Nightly Restored
Comment 17 User image :Gijs 2016-02-24 09:40:38 PST
Considering this only happens with a custom theme, I don't think we will invest in fixing this.

Note You need to log in before you can comment on or make changes to this bug.