Don't allow disabling the navigation toolbar

RESOLVED DUPLICATE of bug 870545

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 870545
5 years ago
5 years ago

People

(Reporter: limi, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Users can currently disable the navigation toolbar, and get Firefox into a state where it's unusable. We should protect them against this.

If people actually need to disable the navigation toolbar, they should use about:config or an add-on.

Comment 1

5 years ago
The option should probably remain available in two cases:
* Full-screen mode
* "Customize Toolbars..." was used to move navigation items to another place

Comment 2

5 years ago
(In reply to Jesse Ruderman from comment #1)
> The option should probably remain available in two cases:
> * Full-screen mode
> * "Customize Toolbars..." was used to move navigation items to another place
(In reply to Alex Limi (:limi) — Firefox UX Team from comment #0)
> about:config
So a new about:config pref would be needed to track whether navigation items were moved to a different toolbar, as that info is currently only in localstore.rdf

Comment 3

5 years ago
People running Firefox in a kiosk or similar setting often want to disable the navigation bar. That said, it doesn't need to be present in the main UI.
And IMHO, safe mode should both not allow disabling stuff like this at all and offer to re-enable if disabled via hidden prefs.
People running Firefox in a kiosk will need to be using a "Kiosk" add-on anyway - there are loads of other changes they'd want. So this can be one of them.

Limi is right. Kill this UI.

Gerv

Updated

5 years ago
Component: General → Toolbars

Comment 5

5 years ago
It seems that Bug 870545 fixed this bug.

Comment 6

5 years ago
(In reply to Morpheus3k from comment #5)
> It seems that Bug 870545 fixed this bug.

So it did, but only on the UX (Australis) branch, where we're doing additional work to make sure the navigation items don't leave the navbar. I'm not sure porting it to m-c in advance of Australis landing is a good idea; you'd need to do a lot of additional work to ensure the navigation items stayed on that bar, otherwise we're forcing users to keep a possibly empty toolbar around. Adding restrictions to customization in its old form is a whole extra load of work, and I don't think moving this forward by 0 or 1 version (given that we're trying to land Australis for 24 (current nightly) or 25) is worth the extra effort.

So I think it'd make sense to wait and close this bug when bug 870545 gets merged to m-c.
Depends on: 870545

Updated

5 years ago
No longer blocks: 851698
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 870545
Resolution: --- → DUPLICATE
Duplicate of bug: 870545
You need to log in before you can comment on or make changes to this bug.