Closed Bug 851761 Opened 7 years ago Closed 7 years ago

Australis tabs start and end are not drawing properly sometimes

Categories

(Firefox :: Theme, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: mconley, Assigned: MattN)

References

()

Details

Attachments

(1 file)

Reddit user ComradeYoldas noticed this on UX:

http://i.imgur.com/mBsfQDx.jpg [1]

Matt - any idea what's happening here?
Duplicate of this bug: 851762
Hit enter too soon, and accidentally created two bugs simultaneously. Bugzilla is being hilarious tonight.

The [1] refers to the original Reddit thread where I saw this:  http://www.reddit.com/r/firefox/comments/1ad2h7/does_ayone_know_why_my_tabs_are_acting_this_way/
Summary: Australis tabs are not drawing properly sometimes → Australis tabs start and end are not drawing properly sometimes
I thought this was a known bug so i never filed it, but this how UX with a new profile looks for me on windows 8 with the "aero light" theme applied.
To clarify, it looks the same with the default theme.
I cannot reproduce this on Windows 7 which I believe is shown in comment 0. I can only reproduce on Windows 8 by bringing back the hidden Aero Lite theme by following http://www.askvg.com/how-to-enable-hidden-aero-lite-theme-in-windows-8-rtm/ 

Either some aero styles are in the -moz-windows-default-theme block when they shouldn't be or maybe it's another -moz-windows-compositor issue which can be solved by switching the selector to -moz-windows-glass.
Assignee: nobody → mnoorenberghe+bmo
Status: NEW → ASSIGNED
This should be fixed with the new patches in bug australis-tabs-win (attachment 726527 [details] [diff] [review])
There was a ruleset there that was causing the problem and I don't think it was needed anymore anyways.
https://bugzilla.mozilla.org/attachment.cgi?oldid=722700&action=interdiff&newid=726527&headers=1#a/browser/themes/windows/browser-aero.css_sec3

This will be fixed in UX within a few days.
Fixed in attachment 726527 [details] [diff] [review] of bug 738491.

Confirmed by http://forums.mozillazine.org/viewtopic.php?p=12756611#p12756611

Reopen if this is not fixed on the latest UX build.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I can reproduce this with:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130507 Firefox/23.0

It's actually quite worse with certain lightweight themes, but I can also tell something is off without one.  On my screen, it almost looks like the middle portion of the tab is light brown, while the curved portions are the light blue.  I figured it had to be something with my monitor, but then when I saw it with some lightweight themes, I no longer think that's the case.

I've turned off hardware acceleration and disabled all my extensions.  I can post a screen grab if anything thinks it will have value.

In the event this turns out to be some sort of hardware related problem:
GPU1:  NVIDIA Quadro K1000M, driver version:  9.18.13.1150
GPU2:  Intel(R) HD Graphics 4000, driver version:  9.17.10.2867

This lightweight theme is a good example of one that makes the problem really "shine":
https://addons.mozilla.org/en-US/firefox/addon/yakuza-paint/
You need to log in before you can comment on or make changes to this bug.