Closed Bug 851850 Opened 9 years ago Closed 9 years ago

build failure PPC64: undefined reference to `qcms_transform_data_rgb_out_lut_altivec

Categories

(Core :: GFX: Color Management, defect)

21 Branch
PowerPC
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla22

People

(Reporter: stevensn, Assigned: stevensn)

Details

Attachments

(1 file)

Building firefox on ppc64 (fedora 18) I get 



../../gfx/qcms/transform.o:(.toc+0x80): undefined reference to `qcms_transform_data_rgb_out_lut_altivec'
../../gfx/qcms/transform.o:(.toc+0x88): undefined reference to `qcms_transform_data_rgba_out_lut_altivec'
collect2: error: ld returned 1 exit status
make[1]: *** [libxul.so] Error 1
make[1]: Leaving directory `/home/ssinger/build-out.ppc64/toolkit/library'

This appears to have been caused by bug 817153 taking into account only ppc and not ppc64
This patch adjusts the platform check to match both ppc64 and ppc
Attachment #725828 - Flags: review?(jmuizelaar)
Attachment #725828 - Flags: review?(jmuizelaar) → review+
Attachment #725828 - Flags: checkin?
Attachment #725828 - Flags: checkin?
https://hg.mozilla.org/mozilla-central/rev/fe010206e5ad
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
You need to log in before you can comment on or make changes to this bug.